Fix automation on AudioBufferSourceNode.playbackRate

RESOLVED FIXED in Firefox 24

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: padenot, Assigned: padenot)

Tracking

unspecified
mozilla25
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24+ fixed, firefox25+ fixed)

Details

(Whiteboard: [blocking-webaudio+][qa-])

Attachments

(1 attachment)

No description provided.
Posted patch patchSplinter Review
Comment on attachment 773953 [details] [diff] [review]
patch

This fixes wubwubwub and other testcases I had lying around. I'll write a test as soon as I have the AudioParam.value returning the actual value (which is close).
Attachment #773953 - Flags: review?(ehsan)
Comment on attachment 773953 [details] [diff] [review]
patch

Review of attachment 773953 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this is exactly what I was thinking about.  Can you please remove the code path to handle a null source in ConvertTimeToTickHelper::Convert?  (As this is the last consumer of that code, that should be fine.)  r=me with that.
Attachment #773953 - Flags: review?(ehsan) → review+
Whiteboard: [blocking-webaudio+]
ha, I must have forgot to qref, it was supposed to be in this patch. It was indeed the only consumer.
https://hg.mozilla.org/mozilla-central/rev/216b74874ef0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
We'll take a fix in 24 on Aurora for this. Please nominate when you get the chance. Thanks!
Keywords: checkin-needed
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [blocking-webaudio+] → [blocking-webaudio+][qa-]
You need to log in before you can comment on or make changes to this bug.