Closed Bug 89253 Opened 19 years ago Closed 15 years ago

Fix to bug 19265 doesn't fix the bidi case

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 299838

People

(Reporter: smontagu, Assigned: smontagu)

References

Details

Attachments

(1 file)

I just noticed that the fix to bug 19265 doesn't take into account the case
where embedding level is odd (i.e. the frame is right-to-left).
Attached patch suggested patchSplinter Review
Hmmm.... the attached patch /ought/ to work, but there seems to be another bug
here obscuring the issue. The patch makes the caret display at the correct
location, but the text already entered starts scrolling off to the right (and
does the same in builds without the patch).

Why don't you take this bug?
Assignee: karnaze → simon
Component: Layout → BiDi Hebrew & Arabic
Keywords: patch
Blocks: 115711
Status: NEW → ASSIGNED
Blocks: 152111
Bug 299838 has a testcase and an up-to-date patch.

Prog.

*** This bug has been marked as a duplicate of 299838 ***
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: chrispetersen → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.