cfx run behaves different cfx xpi: cfx run includes third-party data/ directories, cfx xpi does not

RESOLVED WONTFIX

Status

Add-on SDK
General
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: robwu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

147.62 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 774640 [details]
firefox-addon.zip

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130625173050

Steps to reproduce:

Using `cfx xpi`, build an addon that depends on a third-party Jetpack module which has files in its data directory.

1. Create a Firefox add-on which depends on a third-party module (see attachment, firefox-addon.zip).
2. Run cfx xpi
3. Install the output xpi file (firefox-addon.xpi, also included in the zip file in the attachment) in Firefox

Tested using
- Firefox 22.0
- Add-on SDK 1.14 (39467a307f58b63c1907c8d383e48475c98b0624)


Actual results:

The addon does not function correctly, because the contents of the data directory of the third-party module is not included in the output xpi file.


Expected results:

The contents of the data/ directories of all third-party modules should have been included in the xpi file.

This works fine in cfx run/cfx test, so it's specific to `cfx xpi`.
(Reporter)

Updated

5 years ago
Summary: cfx xpi does not add third-party data/ directories to the xpi file → cfx run behaves different cfx xpi: cfx run includes third-party data/ directories, cfx xpi does not
P1 to at least find out what's happening.
Priority: -- → P1
In bug 915376 we will drop our traditional third-party packages support in favor of npm style 3rd party packages, so even if this bug is real I don't think that we should bother fixing it at this point.
Priority: P1 → --
http://work.erikvold.com/jetpack/2014/01/03/jetpack-in-the-future.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.