Closed Bug 893013 Opened 7 years ago Closed 7 years ago

Add Optional Pref to place Find-bar at top or bottom of the browser

Categories

(Firefox :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox25 - ---

People

(Reporter: jmjjeffery, Unassigned)

References

(Blocks 1 open bug)

Details

After the landing of https://bugzilla.mozilla.org/show_bug.cgi?id=869543 placing the Find-bar at the top of the content window makes for a 'jarring' experience using the Quick-find function with the page 'jumping' up/down during activation and fade-out of the Find-bar on timeout.

There should be a pref added to allow the user the option of placing the Find-bar at the top or bottom of the browser content window.
A better solution to this problem is simply not to shift the page at all. Instead, the scroll position is changed slightly so that the page appears to stand still as the find bar comes down. For most pages, this should work flawlessly. The only issue I can think of is objects that are fixed to the top of the viewport. This is much better solution than to add a preference and ask users to decide which solution they prefer.

Safari has done this for years, by the way: http://www.youtube.com/watch?v=RnnDk8yBGT0

Bug 248715 is about is specifically about this issue, applied to toolbars in general.
(In reply to David Regev from comment #1)
> ... This is much better solution than to add a preference
> and ask users to decide which solution they prefer.
> 

I humbly yet adamantly disagree.
We definitely need some way to not move the page down when using find.
A pref is the wrong solution here. If the new findbar UX is unacceptable, then we need to either fix it (ala comment 1) or back it out if we can't find an acceptable solution.

Nor should we add a pref simply because someone wants it at the bottom instead of the top (UX concerns aside).

I'll file a new bug to track the UX issue.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
(In reply to Justin Dolske [:Dolske] from comment #4)

> I'll file a new bug to track the UX issue.

Bug 893446, for those playing along at home.
(In reply to David Regev from comment #1)
> 
> Safari has done this for years, by the way:
> http://www.youtube.com/watch?v=RnnDk8yBGT0
>

This is completely bad Idea.
FindBar should not obscure any item of contents.
Because the important item including an account info and a search box and menus is often put in the upper part of the page.
I really don't see why we needed this change, and I agree about safari find bar being a bad idea.
Can it be moveable/draggable (top/bottom)? Or maybe allow the user to choose its position in about:config?
I mean, i am not complaining about it hiding content or shifting the content position. Most of users are already used to the findbar on the bottom and for some(like me) it can be extremely irritating having it on top and not being able to change it back to the place where i was used to have it.
If you're interested in at least a temporary fix while the devs try to sort out what they're going to do with this, you can get the findbar back to the bottom by editing your user userChrome.css.

Just add this code, which was kindly provided by ARIS in the Mozilla Forum.

*/
 .browserContainer > findbar{
  -moz-box-ordinal-group: 10 !important;
}
/*

Ref. http://forums.mozillazine.org/viewtopic.php?f=23&t=2729381&sid=222a5e5d40dc93fdd67585c89eee7dd9
As Dolske pointed out in comment 4, we will not be moving the findbar back to the bottom, nor adding a pref to about:config to do so. Hence the resolved status of this bug.

The code that Joe Greenman wrote might help you, but that's not something we can officially support.

Thank you for your understanding.
(In reply to Mike de Boer [:mikedeboer] from comment #10)
> As Dolske pointed out in comment 4, we will not be moving the findbar back
> to the bottom, nor adding a pref to about:config to do so. Hence the
> resolved status of this bug.
> 
> The code that Joe Greenman wrote might help you, but that's not something we
> can officially support.
> 
> Thank you for your understanding.

The elegance of Firefox has always been - and will always remain - its flexibility in permitting interested, talented, and creative people to modify it. 

"Management decisions" are made and implemented in every project. I understand this. The only thing the Mozilla devs have to "officially support" is Fx's inherent capacity for modification.

Oh, and just to keep things straight, I didn't "write" the code in the sense of "produce" it; I merely copied and pasted it. 

Of the three attributes I mentioned - interested, talented, and creative - unfortunately, the only one that applies to me is "interested". 
:-(
(In reply to Mike de Boer [:mikedeboer] from comment #10)
> Thank you for your understanding.

What understanding? You're making another stupid UI decision, what else is there to understand?
(In reply to Joe Greenman from comment #9)
> If you're interested in at least a temporary fix while the devs try to sort
> out what they're going to do with this, you can get the findbar back to the
> bottom by editing your user userChrome.css.
> 
> Just add this code, which was kindly provided by ARIS in the Mozilla Forum.
> 
> */
>  .browserContainer > findbar{
>   -moz-box-ordinal-group: 10 !important;
> }
> /*
> 
> Ref.
> http://forums.mozillazine.org/viewtopic.
> php?f=23&t=2729381&sid=222a5e5d40dc93fdd67585c89eee7dd9

Thanks for sharing that code! I added a small customization to it.
.browserContainer > findbar{
  -moz-box-ordinal-group: 10 !important;
}
.findbar-closebutton {
  margin-right: 1400px !important
}
.findbar-textbox {
  width: 30em !important;
}
Looking a lot better now.
(In reply to Joe Greenman from comment #9)
> If you're interested in at least a temporary fix while the devs try to sort
> out what they're going to do with this, you can get the findbar back to the
> bottom by editing your user userChrome.css.
> 
> Just add this code, which was kindly provided by ARIS in the Mozilla Forum.
> 
> */
>  .browserContainer > findbar{
>   -moz-box-ordinal-group: 10 !important;
> }
> /*
> 
> Ref.
> http://forums.mozillazine.org/viewtopic.
> php?f=23&t=2729381&sid=222a5e5d40dc93fdd67585c89eee7dd9

Thanks for sharing that code! I added a small customization to it.
.browserContainer > findbar{
  -moz-box-ordinal-group: 10 !important;
}
.findbar-closebutton {
  margin-right: 1400px !important
}
.findbar-textbox {
  width: 30em !important;
}
Looking a lot better now.
Thank you Pache. You've corroborated my contention about how interested, talented, and creative people have always made, and hopefully will continue to make, Firefox the best browser out there.

As for randyzie's observation, while I certainly sympathize with some of the sentiment it contains, I think it's important to try to consolidate rather than fragment the "Firefox community", which certainly comprises the devs and Mozilla as a whole.

Mike de Boer's emphasis on the distinction between "you" and we", unfortunately, seems to go in the opposite direction.
(In reply to Joe Greenman from comment #15)
> Mike de Boer's emphasis on the distinction between "you" and we",
> unfortunately, seems to go in the opposite direction.

Joe, I'm afraid you misunderstood the context of my usage of the words 'you' and 'we'. It was certainly not used to instigate a chasm between the Firefox Community and devs/ Mozilla as you put it. That would be silly. Please don't twist words.

As a more general note: Bugzilla isn't a discussion forum. If you've got constructive new information please take it to firefox-dev, but this has already been debated and the bar for revisiting the issue is high. If you'd like to revert to the old findbar placement, you can use the user CSS as provided in comment 9 or create/ use an add-on that adds the functionality you require.

Again, thank you for your understanding.
(In reply to Mike de Boer [:mikedeboer] from comment #16)
> (In reply to Joe Greenman from comment #15)
> > Mike de Boer's emphasis on the distinction between "you" and we",
> > unfortunately, seems to go in the opposite direction.

> Joe, I'm afraid you misunderstood the context of my usage of the words 'you'
> and 'we'. 

Mike, I'm a native speaker of English and have taught the language at universities around the world for forty years. I'm also a trained linguist. I didn't misunderstand anything; I read what you wrote and then interpreted it in the "context" of my Weltanschauung. 

I think it would have been better for you to write in Comment 16 that you didn't express what you wanted to say carefully and accurately enough.

> It was certainly not used to instigate a chasm between the 
> Firefox Community and devs/ Mozilla as you put it.

I never alluded to your intention but rather to the attitude that I felt was reflected in your use of "you" and "we". I wrote "seems to" (i.e. seems to me), which clearly states my personal opinion, which I believe I'm entitled to express.   

> That would be silly. Please don't twist words.

I didn't; I stated my opinion. You, here, however, appear to be assuming an intention on my part. 

> As a more general note: Bugzilla isn't a discussion forum ...

Thank you.

> Again, thank you for your understanding.

You're most welcome. 

(End of communication)
I really don't understand this. In Bug 869543 Comment 17, Mike de Boer calls the idea of findbar position being configurable "reasonable" and explicitly asks Jim Jeffery to open a bug for it. When he does so, the bug is almost immediatelly closed as WONTFIX (and called "wrong solution") without any explanation or at least hint of a reason and the same Mike de Boer who asked for its creation supports this decision wholeheartedly and again without any hint about what did change his mind.

I spend quite a lot of time on the other side of bugzilla (not this one) and I never close a bug as WONTFIX without trying to explain why we are not going to fix the issue or implement an enhancement. I would consider this impolite. And I can't imagine I'd be supporting such action after explicitely asking the reporter to create the bug.
You need to log in before you can comment on or make changes to this bug.