Closed Bug 893316 Opened 7 years ago Closed 7 years ago

Http.jsm doesn't listen to method option parameter

Categories

(Toolkit :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(2 files)

Thunderbird's cloudfile tests are failing since bug 884319 landed because Http.jsm has a tiny bug in it - it doesn't pay attention to the method that the caller passes in. So it sticks to its defaults.

Working on a patch.
Attached patch Patch v1Splinter Review
Lemme whip up a test real quick.
Attached patch Regression testSplinter Review
Spot the nerdy comp-sci joke!
Attachment #775086 - Flags: review?(dtownsend+bugmail)
Attachment #775087 - Flags: review?(dtownsend+bugmail)
(In reply to Mike Conley (:mconley) from comment #0)
> Thunderbird's cloudfile tests are failing since bug 884319 landed because
> Http.jsm has a tiny bug in it - it doesn't pay attention to the method that
> the caller passes in. So it sticks to its defaults.
> 
> Working on a patch.

Oh, doh. That's a very silly bug, sorry about that. Not that I can actually r+ this, but the change looks fine to me. Thanks for looking as this Mike.
Attachment #775086 - Flags: review?(dtownsend+bugmail) → review+
Attachment #775087 - Flags: review?(dtownsend+bugmail) → review+
You need to log in before you can comment on or make changes to this bug.