All users were logged out of Bugzilla on October 13th, 2018

Duplicate requests sometimes appearing in the network monitor

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
5 years ago
4 months ago

People

(Reporter: vporof, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 775558 [details]
test.html

STR:

1. Create a simple test.html document (use the attached file for example).
2. Start a server in that directory, for example using python
> python -m SimpleHTTPServer 1234
3. Open the simulator dashboard
4. "Add URL" for http://localhost:1234/test.html as an in the simulator
5. Click "Connect" for the newly installed app
6. Go to the Network Monitor
7. Refresh the app in the simulator (either via the Refresh button in the dashboard, or cmd/ctrl+R on the app itself)

The first GET request for test.html sometimes appears 2 or even 3 times in the requests menu. All the data for this request is the same, except for the content which is empty for all but the last one.

Sometimes this also happens in the webconsole, but I cannot reproduce it consistently. However, the symptoms seem to be the same: duplicate requests.

Mihai, is the webconsole guarding against such things? Can a networkEvent packet be sent multiple times for the same request?

This doesn't look like a simulator bug from my brief crude investigations (print something on load).
Maybe the request channel object is changing during the request lifetime? See NRL__findOpenResponse() and NM_observeActivity() -- how they identify the same request. I haven't seen this issue with b2g desktop builds.

Can you please investigate with additional debugging/logging inside the two functions?
(Reporter)

Comment 2

5 years ago
Sure, that's the plan!
(Reporter)

Updated

5 years ago
Priority: -- → P3

Comment 3

2 years ago
Created attachment 8859466 [details]
work_for_me.png

I have the impression this is no longer relevant. I followed the STR but the problem doesn't show up with

>Version 	55.0a1
>Build ID 	20170413080758
>User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
and
>Version 	52.0.2
>Build ID 	20170329150849
>User Agent 	Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Flags: needinfo?(odvarko)
Yeah, I think it's safe to close this one.

Thanks for testing!

Honza
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(odvarko)
Resolution: --- → WORKSFORME

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.