Closed Bug 893740 Opened 7 years ago Closed 7 years ago

Make better use of Services.* in SeaMonkey's about.xhtml page

Categories

(SeaMonkey :: General, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.22

People

(Reporter: rsx11m.pub, Assigned: rsx11m.pub)

References

()

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #893547 +++

(Quoting Philip Chee from bug 893547 comment #11)
> > +      Components.utils.import("resource://gre/modules/Services.jsm");
> Can I suggest (perhaps in a followup bug):
> 1) Move the Services.jsm import to the top of the script.
> 2) Use Services for nsIURLFormatter, nsIXULAppInfo
Keywords: regression
Summary: Make better use of Services.* in the about: page → Make better use of Services.* in SeaMonkey's about.xhtml page
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
Attached patch Proposed patch (obsolete) — Splinter Review
Modifications as suggested, along with some blank-line removals.
This is only intended for comm-central.
Attachment #777529 - Flags: review?(neil)
Comment on attachment 777529 [details] [diff] [review]
Proposed patch

>     <script type="application/javascript">
>       // get release notes URL and vendor URL from prefs
>+      Components.utils.import("resource://gre/modules/Services.jsm");
Really at the top please, and with a blank line before the comment to separate it too.

>+      var formatter = Services.urlFormatter;
...
>       var releaseNotesURL = formatter.formatURLPref("app.releaseNotesURL");
I know it might make the line a bit long but I'd prefer it if you just referenced Services.urlFormatter directly in both places.
Attachment #777529 - Flags: review?(neil) → review+
Attachment #777529 - Attachment is obsolete: true
Attachment #777735 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/cf1808a78282
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.22
You need to log in before you can comment on or make changes to this bug.