When connection to proxy fails, the report states that "Connection to www.foo.org failed"

VERIFIED DUPLICATE of bug 56629

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 56629
17 years ago
17 years ago

People

(Reporter: Alexey Mahotkin, Assigned: Matthew Paul Thomas)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3 i686; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050521

When our proxy for some reason refuses connections, the error message from
Mozilla says "Connection to www.foo.org failed".  

Reproducible: Always
Steps to Reproduce:
1. Setup some fake port (where no one is listening) as proxy
2. Try to go to any http://www.mozilla.org/


Actual Results:  "The connection was refused when contacting www.mozilla.org"
error message. 

Expected Results:  It should say that "Connection to proxy
proxy.example.org:3128 refused"

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 56629 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: User Interface Design → Networking
Resolution: --- → DUPLICATE

Comment 2

17 years ago
VERIFIED:
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.