Closed Bug 894129 Opened 9 years ago Closed 9 years ago

Move base/resources/xml-v11/preferences_customize_tablet.xml to resources/xml-xlarge-v11/preferences_customize.xml

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: liuche, Assigned: liuche)

Details

Attachments

(1 file)

Instead of using two different preferences in xml-v11, we should be (creating and) using the tablet-specific xml directory, xml-xlarge*.
Tablet uses xlarge res, so tablet resources in xml-v11 should instead be in xml-xlarge-v11.
Assignee: nobody → liuche
Status: NEW → ASSIGNED
Attachment #776866 - Flags: review?(bnicholson)
So it would appear that unfortunately, there are devices that are both multipane *and* don't use xlarge resources. That's the cause of the failure in the try push, on rc2. The device is using phone resources (which don't include Sync in a specific submenu) while being multipane, so the Sync menu item is not actually present.

I'll have to think about this one some more...
Comment on attachment 776866 [details] [diff] [review]
Patch: move tablet res to xml-xlarge-v11 v1

Clearing review flag, since this is broken on certain phones that think they are tablets (or maybe the other way around). This may end up being a WONTFIX if Android doesn't provide enough fine-grained control.
Attachment #776866 - Flags: review?(bnicholson)
Sizing of tablets vs hi-res phones was still a problem last I looked at this, so WONTFIX-ing this.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.