"Assertion failure: !mIsOffline" [@ mozilla::dom::AudioContext::Unmute]

VERIFIED FIXED in Firefox 24

Status

()

Core
Web Audio
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: adw)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla25
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24+ verified, firefox25+ verified)

Details

(Whiteboard: [blocking-webaudio+])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 776207 [details]
testcase

Assertion failure: !mIsOffline, at content/media/webaudio/AudioContext.cpp:549

Easier to reproduce on Windows, but happens on Mac too.
(Reporter)

Comment 1

5 years ago
Created attachment 776212 [details]
stack
(Assignee)

Comment 2

5 years ago
Created attachment 776589 [details] [diff] [review]
guard against audioContext->IsOffline()
Attachment #776589 - Flags: review?(ehsan)

Updated

5 years ago
Attachment #776589 - Flags: review?(ehsan) → review+

Updated

5 years ago
Assignee: nobody → adw
status-firefox24: --- → affected
status-firefox25: --- → affected
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?

Updated

5 years ago
Whiteboard: [blocking-webaudio+]
(Assignee)

Updated

5 years ago
Blocks: 879111
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Comment 3

5 years ago
Drew, can you please ask for Aurora approval once this lands?

Updated

5 years ago
tracking-firefox24: ? → +
tracking-firefox25: ? → +
https://hg.mozilla.org/mozilla-central/rev/352b3d608ade
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox25: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
(Assignee)

Comment 6

5 years ago
Comment on attachment 776589 [details] [diff] [review]
guard against audioContext->IsOffline()

[Approval Request Comment]
Forwarding Ehsan's request for Aurora approval in comment 3.

Bug caused by (feature/regressing bug #): bug 879111
User impact if declined: minimal
Testing completed (on m-c, etc.): no automated testing
Risk to taking this patch (and alternatives if risky): very very low
String or IDL/UUID changes made by this patch: none
Attachment #776589 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #776589 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0

Verified as fixed on Windows 7 x64, Mac OS X 10.8, Ubuntu 12.04 x32 with Firefox 24 beta 8 (buildID: 20130902131354) and latest Nightly (buildID: 20130902030220).
status-firefox24: fixed → verified

Comment 9

5 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Verified as fixed with Firefox 25 beta 4 (Build ID: 20131001024718) on Windows 7 x64, Mac OS X 10.8 and Ubuntu.
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
You need to log in before you can comment on or make changes to this bug.