Defect - Blank space remains after the scrollbars hide

RESOLVED DUPLICATE of bug 930771

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 930771
6 years ago
6 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Trunk
x86
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments)

Posted image screenshot
Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130715 Firefox/25.0

After the scrollbars are dismissed, there is some blank spare remaining instead of them. The space is almost as high as the horizontal scrollbar and for the vertical bar it thinner.

Steps to reproduce:
1. Open a page which has scrollbars
2. Move the mouse so that the scrollbar(s) appear
3. Wait a few seconds for the scrollbars to disappear

Expected result: when scrollbars disappear (hide) the bage content should be displayed instead

Actual result: blank space is displayed instead of page content. The space is almost as high as the horizontal scrollbar and for the vertical scrollbar it is thinner, only a few pixels width.

See attached screenshot for details.
Whiteboard: feature=defect c=tbd u=tbd p=0
Priority: -- → P3

Updated

6 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0 → [preview-triage] feature=defect c=tbd u=tbd p=0
I see this odd behavior on text areas that have overflow: scroll set.
This might be a known issue with out hover scrollbars. Spohl, have you ever seen this?
Flags: needinfo?(spohl.mozilla.bugs)
Hmm, we used to see something similar to this on OSX when the page was zoomed in (bug 868416). There, we removed negative margins from nativescrollbars.css for OSX and started computing them dynamically in cross-platform code based on the page zoom level. But looking at xulscrollbars.css[1] and the fact that negative margins are gone there too, it seems like the same fix was applied to Win8. Does this problem here depend on zoom level at all? If not, I'd want to look for a place that doesn't add margins to scrollbar frames, i.e. a place that forgets to call nsScrollbarFrame::GetMargin directly, or indirectly via AddMargin. I'm pretty sure this used to be unnecessary because regular scrollbars didn't have a margin. However, now we add negative margins to get the 'overlay' effect.

[1] http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/xulscrollbars.css
Flags: needinfo?(spohl.mozilla.bugs)
Zoom doesn't play into this. You do have to have the overflow: scroll set though. Not sure about large images, I imagine overflow:scroll is the default on a browser containing one of those.
This might also be a layers/paint issue, hard to say.
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
No longer blocks: metrov2defect&change

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930771
No longer blocks: metrobacklog
Whiteboard: feature=defect c=tbd u=tbd p=0
You need to log in before you can comment on or make changes to this bug.