Closed Bug 894597 Opened 11 years ago Closed 11 years ago

TaskThrottler::TaskComplete shouldn't call nsTArray::RemoveElementAt(0) on an empty array

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 895722
mozilla25

People

(Reporter: justin.lebar+bug, Assigned: justin.lebar+bug)

References

Details

Attachments

(1 file)

My B2G trunk build is crashing sometimes when I load a bunch of apps and then kill them with

 $ adb shell kill -9 $(adb shell b2g-info -c)

I think this is because TaskThrottler::TaskComplete calls nsTArray::RemoveElementAt(0) on an empty nsTArray.

I'll attach a patch which naively puts a guard in place, but I have no idea if this is right.
This blocks bug 893012 because it's keeping me from being able to test it.  I'd guess that this bug probably is not present on b2g18, since we just refactored layers.
Blocks: 893012
Attached patch Patch, v1Splinter Review
Attachment #776666 - Flags: review?
Attachment #776666 - Flags: review? → review?(ajones)
Comment on attachment 776666 [details] [diff] [review]
Patch, v1

Review of attachment 776666 [details] [diff] [review]:
-----------------------------------------------------------------

Happy to see this landed. It will be superseded by bug 888084 otherwise.
Attachment #776666 - Flags: review?(ajones) → review+
Assignee: nobody → justin.lebar+bug
https://hg.mozilla.org/mozilla-central/rev/1d69e824c557
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Justin, it looks like you landed an empty changeset.
Status: RESOLVED → REOPENED
Flags: needinfo?(justin.lebar+bug)
Resolution: FIXED → ---
Well, that's cool.
Flags: needinfo?(justin.lebar+bug)
The code now does

  if (mMaxDurations > 0) {
      if (mDurations.Length() >= mMaxDurations) {
          mDurations.RemoveElementAt(0);
      }
      mDurations.AppendElement(aTimeStamp - mStartTime);
  }

so we're good.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: