[Buri][Contacts]It can not displayed contact's name

RESOLVED DUPLICATE of bug 890909

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED DUPLICATE of bug 890909
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: gduan)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(1 attachment)

log
458.91 KB, text/plain
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 Created an attachment (id=459569)
 log
 
 DEFECT DESCRIPTION:
  It can not displayed contact's name
  REPRODUCING PROCEDURES:
  1.Add two contacts,A 1388855522288 and B 443443
  2.Input 443443,and dial it,it displayed B--->OK
  3.Input 1388855522288,and dial it,it displayed Number,Can't displayed contact's nmae----->KO
  EXPECTED BEHAVIOUR:
  It should displayed A.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
  SWV171+ZZ
  USER IMPACT:
  Mid
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 776861 [details]
log

Updated

5 years ago
blocking-b2g: --- → leo?
Assignee: nobody → gduan
I think the problem may comes from mozContact with 'match' op.
Below numbers also fail to return right contact.
1234567890
1234567891
123456789012

however,
12345678901 success.
I will check with backend team.
Hi Gregor,  

I have some questions about mozContact API. As you can see in comment 3 , it might return me no result if input more than 10 digits with 'match' . I'm wondering if it's expected. Thanks.
Flags: needinfo?(anygregor)
(In reply to George Duan [:gduan] from comment #3)
> I think the problem may comes from mozContact with 'match' op.
> Below numbers also fail to return right contact.
> 1234567890
> 1234567891
> 123456789012
> 
> however,
> 12345678901 success.
> I will check with backend team.

Can you provide more details please? What number did you store exactly? They are different from the Description.
Did you use a phone with a SIM card? What country are you testing in?
The match behavior has many variables.
Flags: needinfo?(anygregor)
As discussed with Gregor, bug 890909 may solve this bug.
We'll wait til patch of bug 890909 merged into build and verify it.
Depends on: 890909
blocking-b2g: leo? → leo+
This bug is solved with build 20130719070222 on inari. 
gecko: 6565d51b22a1ce191e18e923f0777723f73688a3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890909
You need to log in before you can comment on or make changes to this bug.