Audio is busted with 5.1 speakers

RESOLVED DUPLICATE of bug 893307

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 893307
5 years ago
a year ago

People

(Reporter: Ge3k0s, Unassigned)

Tracking

({regression})

25 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox25- affected)

Details

Attachments

(1 attachment)

241.67 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
The last few days I've encountered an issue concerning the sound in Firefox 25 that I can't reproduce in 22. When I normally use my 5.1 speakers the sounds in the browser are completely messed up, when I change my settings to 2.1 it sounds perfectly fine. Plugins aren't concerned (for example the sound of flash videos work just fine).

Comment 1

5 years ago
If you think it has regressed, could you use the tool mozregression (see http://harthur.github.io/mozregression/ for details) to find a possible regression range, please.
Component: General → Untriaged
Flags: needinfo?(ge3k0s)
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

5 years ago
I don't know if it's the right info but here's what I've found:

Last good nightly 2013-07-10
First bad nightly 2013-07-11

Pushlog : http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04d8c309fe72&tochange=dde4dcd6fa46
Flags: needinfo?(ge3k0s)

Comment 3

5 years ago
Yes, that's we need. :)

There are some bugs about audio: Bug 891543, Bug 888271
But I don't know if they are involved.

Alice, do you have 5.1 speakers to test?
Flags: needinfo?(alice0775)
Keywords: regression

Comment 4

5 years ago
no, i do not have.
Flags: needinfo?(alice0775)

Comment 5

5 years ago
I don't think you need 5.1 speakers, just manually set speaker setup to 5.1? And yeah, I'm affected by this bug too. And happens only on the 64-bit Nightlies. 32-bit is ok.

Comment 6

5 years ago
(In reply to dgjunk from comment #5)
> I don't think you need 5.1 speakers, just manually set speaker setup to 5.1?

OK, I tried.

STR
0. Setup 5.1 speakers from Realtek HD audio manager
1. Open http://www.brucewiggins.co.uk/?p=265
2. Play back OGG/AAC audio

There are two regressions:
#1 no sound(OGG, AAC)
#2 sound distortion(OGG), no sound(AAC)

#1 Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/26f83c4cb81e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130709 Firefox/25.0 ID:20130709022917
Bad: no sound
http://hg.mozilla.org/integration/mozilla-inbound/rev/ebdf97f9ec52
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130709 Firefox/25.0 ID:20130709030058
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=26f83c4cb81e&tochange=ebdf97f9ec52

Regressed by:
ebdf97f9ec52	Paul Adenot — Bug 866675 - Add a WASAPI backend to cubeb. r=kinetik



#2 Regression window(m-i)
Bad: no sound
http://hg.mozilla.org/integration/mozilla-inbound/rev/e47b0cd496f8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130711 Firefox/25.0 ID:20130711141537
Bad: sound distortion(OGG), no sound(AAC)
http://hg.mozilla.org/integration/mozilla-inbound/rev/e080b87c18a5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130711 Firefox/25.0 ID:20130711143936
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e47b0cd496f8&tochange=e080b87c18a5

Regressed By: Bug 891773
Blocks: 866675
Status: UNCONFIRMED → NEW
tracking-firefox25: --- → ?
Component: Untriaged → Video/Audio
Ever confirmed: true
Keywords: regressionwindow-wanted
Product: Firefox → Core

Comment 7

5 years ago
The bug number of commit massage for 440da67cf398 and e080b87c18a5 is wrong.
It should be Bug 790459.

And #2regressin is
s/Regressed By: Bug 891773/Regressed By: Bug 790459/
Blocks: 790459

Comment 8

5 years ago
I can confirm that having Windows setup for 5.1 audio channels causes this as the problem no longer exists when changing to Stereo.  I did not test if the problem exits for Quadraphonic or 7.1 settings.  For those who don't have Realtek integrated audio, you can also reproduce by doing the following on Vista/Win7:

1. Open the Sound panel from Control Panel
2. Select Speakers and click Configure
3. Select 5.1 Surround in the window that pops up and keep clicking Next as many times as it asks then click Finish.
4. Open any page with HTML5 Audio/Video and the sound is distorted or doesn't play at all.

Bug 893307 is likely related to this.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893307
status-firefox25: --- → affected
tracking-firefox25: ? → +

Comment 10

5 years ago
I can still reproduce the problem with STR comment#6

http://hg.mozilla.org/mozilla-central/rev/73b69c146ca6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130728 Firefox/25.0 ID:20130728030204
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The Vorbis and Opus multichannel files are downmixed to stereo inside the decoder. The output is always stereo sound even if the input is multichannel.
Alice, which problem can you repro? Comment 6 lists two regressions. #2 should be fixed by bug 893307.
Flags: needinfo?(alice0775)
(Reporter)

Comment 13

5 years ago
The problem isn't completely fixed by me either. The audio is now more or less decent, but there are a lot of noise in the background.
Can someone provide a recording so I can make sense of what is happening?

Comment 15

5 years ago
(In reply to Paul Adenot (:padenot) from comment #12)
> Alice, which problem can you repro? Comment 6 lists two regressions. #2
> should be fixed by bug 893307.

In Latest Nightly25.0a1
http://hg.mozilla.org/mozilla-central/rev/73b69c146ca6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130728 Firefox/25.0 ID:20130728030204

I can reproduce the problem ( sound distortion(OGG) and no sound(AAC) both).
Flags: needinfo?(alice0775)

Comment 16

5 years ago
As pointed out by Alice and in Bug 893307, comment 21 audio distortion is still present despite improvements made by Bug 893307.  After looking into this, I have found that audio distortion for mp4/mp3, webm, and ogg were the result of me having set the audio sampling rate, in windows, to something other than 16/24bit, 44100hz (I was using 24bit, 96000hz).  Unfortunately, the supposed opus files located here [1], still seem to suffer from audio distortion even after setting the sampling rate to 16/24bit, 44100hz.  So at least part of this problem seems to be related to how firefox handles audio sample rates.

Alice, I have experienced missing audio from media using the opus codec, but I have not experienced it with vorbis or aac.  Do you have any links that I could check to try and reproduce?

[1] http://people.xiph.org/~xiphmont/demo/opus/demo3.shtml

Comment 17

5 years ago
Yes, this seems to have something to do with hz(and bit?) conversion done badly. On http://html5media.info/ the video file is 48khz, and the audio file is 44,1khz and depending on what your systems default hz setting is, the one that needs conversion sounds bad with clipping etc. All files on http://people.xiph.org/~xiphmont/demo/opus/demo3.shtml are 48khz, so they sound fine if your system is on 48khz, bad if on 44,1khz. And the default hz setting (on windows) can be found here: Control Panel -> Hardware and Sound -> Sound -> Select Speakers -> Properties -> Advanced tab -> Default Format. On my system the default seemed to be on 24bit/48khz.
This is is very useful information. I don't have my Windows setup (the only machine I have that can do 96kHz / 24bits is my music production machine at home) at the moment, but rest assured I'll fix those issues next week.

I'll also look into the sample rate conversion problem you mention. What you say is perfectly logical, since Opus files get decoded at 48kHz, and because your sound card is running at 44.1kHz, we do sample rate conversion. If I got everything right, playing a file with a rate of 44.1kHz should be just fine.

Comment 19

5 years ago
Created attachment 783056 [details]
Dwm 2013-07-30 12-47-00-22.opus

Sample of audio playback. System on 48khz, first played bit of 48khz video file on http://html5media.info/ and then the 44,1khz audio file needing conversion.

Comment 20

5 years ago
I can confirm dgjunk's findings that distortion is the result of the media files sample rate not matching the sample rate selected for the audio device.  In light of this new information, a machine that is able to do 96kHz / 24bits isn't needed.  As long as you select a sample rate that differs from the file you try to play.  Selecting 44.1kHz / 24bits while playing a media file with a rate of 48 kHz is enough to reproduce.
Fwiw, WASAPI in shared mode cannot control the mixer sample rate, but on Windows 7 you can control it to some extent by passing the AUDCLNT_STREAMFLAGS_RATEADJUST flag during initialization, then calling IAudioClockAdjustment::SetSampleRate with the desired sample rate. When I played with this a year or so ago, I found that this can control the sample rate to within 10% or so, enough for 44100 -> 48000 or the inverse.
We are doing resampling manually, because we need to support Vista, and people are sometimes playing, say, 8000Hz files on a hardware clocked at 96kHz.
I'm going to close this bug, the work to solve this got tracked in bug 893307 anyways. Please open new bugs for new issues, thanks.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893307

Updated

5 years ago
tracking-firefox25: + → -
You need to log in before you can comment on or make changes to this bug.