Closed Bug 894805 Opened 7 years ago Closed 7 years ago

[Gallery][Music] Crash observed during Video & Music files saved from MMS application.

Categories

(Core :: Storage: IndexedDB, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED WORKSFORME
1.1 QE4 (15jul)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Crash Data

Attachments

(6 files)

1. Title: Observed Crash when saving Video/Music file from MMS.
2. Precondition: Make sure MMS is  working. 
3. Tester's Action: 
Open Message Composer 
Click on attachment icon -> Add the Audio/Video -> add some text -> Send to the self number
Received MMS
Click on the received audio file 
Seek while audio is playing till last 20 seconds of the audio, wait till last 10 seconds
Click on Save button
 “Music just Crashed” message occurs. 
The same procedure even for Video files.
4. Detailed Symptom (ENG.) : Music/Video  crash
5. Expected : Music/Video should be played and saved well.
6.Reproducibility: Y
7.Frequency Rate : 60%
This is the audio file used for testing.
Audio Save Crash Report
Audio Save Crash DDMS Logs
Video File used for Test
Video Save Crash Report
Video Save Crash DDMS Logs
Flags: needinfo?(gsvelto)
Gabriel,

In the log we can see the crash is in Blobipc.

Regards,
Veeresh
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | mozilla::dom::PBlobChild::Write]
Keywords: crash
Whiteboard: [b2g-crash]
I've tried to reproduce this on my Leo but failed, both using the provided video and audio file. I've tried saving both files 10+ times without ever hitting the issue so I need to know exactly which version of the code you were using when you experienced it:

- Was this on your internal branch on one of the public branches?

- Which Gecko and Gaia branches and revisions where you using?

I've tested on a Leo using the backup-leo directory extracted from the D300_V08j_00_JUL_01_TLF_ES.zip archive. I used the mozilla-b2g18 branch for Gecko, revision 2d17cfb07d0decd59e5df28d64fbef29e9e37317 and the v1-train branch for Gaia, revision c506c50adaaebcf729ac3c27887ba2931ab79040.

If you're using your internal branch since this looks like a blob-related problem be sure to have the patch from attachment 767545 [details] [diff] [review] applied. It was applied to mozilla-b2g18 at revision 933940f006189349274104e10d1d0376fedbb169.
Flags: needinfo?(gsvelto)
Component: Gaia::Music → General
Component: General → IPC
Product: Boot2Gecko → Core
Version: unspecified → Trunk
Sorry for multiple component switch. Looks like an indexed DB crash.
Component: IPC → DOM: IndexedDB
(In reply to Jason Smith [:jsmith] from comment #9)
> Looks like an indexed DB crash.

Looking at the crash-reports they have attached it seems related to blob handling; there's a NULL pointer being accessed in mozilla::dom::PBlobChild::Write(). More importantly that calls is generated from nsDeviceStorage which is consistent with the action being executed (saving a file to the SD-card). Why do you think indexed DB is involved?
(In reply to Leo from comment #0)
> 1. Title: Observed Crash when saving Video/Music file from MMS.
> 2. Precondition: Make sure MMS is  working. 
> 3. Tester's Action: 
> Open Message Composer 
> Click on attachment icon -> Add the Audio/Video -> add some text -> Send to
> the self number
> Received MMS
> Click on the received audio file 
> Seek while audio is playing till last 20 seconds of the audio, wait till
> last 10 seconds
> Click on Save button
>  “Music just Crashed” message occurs. 

I used to encounter this error before. However, after updating the latest b2g18/v1-train build and retrying at least 30 times, I cannot reproduce anymore.
Hi Bent and Patrick, do you have any idea about the attached log? We need experts' opinions.
Hi Leo,

After updating the build to the latest b2g18/v1-train I cannot reproduce this bug anymore (I've tried it all the night)! Could you please come back with a more stable STR if this bug is still present? Thanks!
Flags: needinfo?(leo.bugzilla.gaia)
Hi Leo,
I cannot reproduce this at my side, latest code config from v1-train/b2g18. Can you provide your gecko commit number? Does your build include this patch? https://hg.mozilla.org/releases/mozilla-b2g18/rev/6346d3aaf039
(In reply to Alan Huang [:ahuang] from comment #14)
> Hi Leo,
> I cannot reproduce this at my side, latest code config from v1-train/b2g18.
> Can you provide your gecko commit number? Does your build include this
> patch? https://hg.mozilla.org/releases/mozilla-b2g18/rev/6346d3aaf039

Hi Alan,
We have checked this https://hg.mozilla.org/releases/mozilla-b2g18/rev/6346d3aaf039 and the patch is available in our build.
Flags: needinfo?(leo.bugzilla.gaia)
I just heard from LEO guys at the end of Taipei work week. They said this issue is not reproducing anymore. Maybe we can close this bug.
(In reply to Gene Lian [:gene] from comment #16)
> I just heard from LEO guys at the end of Taipei work week. They said this
> issue is not reproducing anymore. Maybe we can close this bug.

Thanks Gene, I'll close it then as I wasn't able to reproduce it myself on a Leo no matter how hard I tried. If for some reason this shows up again Leo can re-open it.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.