Data connectivity is lost after a few hours in idle (connection icon is not shown in the status bar)

RESOLVED DUPLICATE of bug 909688

Status

RESOLVED DUPLICATE of bug 909688
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

40.67 KB, image/png
Details
3.44 MB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 777002 [details]
screenshot

Reproducible in Ikura
build information:
QC RIL version:
"ro.build.firmware_revision=V1.01.00.01.019.120"
gaia commit:
50abeb2 Merge pull request #10032 from alivedise/bugzilla/872912_v1.0.1b
gecko commit:
a6a5487 Bug 875483 - YouTube HTML5 Playback hangs Firefox. r=derf,a=tef+
build identifier
20130621152332

After a few hours in idle mode, DUT loses data connectivity (it is not possible to access to internet) and data icon (3G) is not shown in the status bar. 

If user checks below status bar, data connection is enabled (3G) but upper status bar does not show connectivity icon. Kindly see screenshot.

Kindly find below the results from the logs analysis made by ZTE R&D team:

Some modification should be made on connection management 

Network will disconnect the data connection when there is no data transport in a long time:
07-17 02:59:43.257 D/RILC    (  116): RIL <--- CM_CALL_EVENT_END(77827), RID 0, MID 0 --- AMSS
07-17 02:59:43.267 D/RILC    (  116): End call call_type 2

But the mobile reconnect to the data network again after a long time(more than 1 hour):
07-17 04:05:44.742 D/RILC    (  116): UI --- RIL_REQUEST_SETUP_DATA_CALL (27) ---> RIL [RID 0, token id 3922, data len 28]
07-17 04:05:49.356 D/RILC    (  116): UI <--- RIL_REQUEST_SETUP_DATA_CALL 

Then data connection dropped again for no data. 
07-17 07:05:49.503 D/RILC    (  116): RIL <--- CM_CALL_EVENT_END(77827), RID 0, MID 0 --- AMSS
07-17 07:05:49.503 D/RILC    (  116): End call call_type 2

And the mobile didn't reconnect to the data network till the end the log.

The mobile should guarantee that has chances to reconnect to network when data dropped.
According to our view, these changes can be made by Mozilla R&D team.
(Reporter)

Comment 1

5 years ago
Created attachment 777003 [details]
logs
(In reply to Firefox_Mozilla from comment #0)
>
> The mobile should guarantee that has chances to reconnect to network when
> data dropped.
> According to our view, these changes can be made by Mozilla R&D team.

Since the RIL we are using it's from Qualcomm, I'm not sure if Mozilla can make this changes. Would you mind to please clarify this?

Anyway, I suggest to nominate this to leo? as connectivity issues are critical and we must ensure this won't happen en leo.
blocking-b2g: --- → leo?
Flags: needinfo?(Firefox_Mozilla)
Since we will work with QC on this issue through their own system, and this issue has not yet been tested with any V1.1-based build, I will better remove the leo? nomination request. 

Once we have more feedback and results on a V1.1-based build, we will let everyone knows here.

BR
blocking-b2g: leo? → ---

Comment 4

5 years ago
Fix for this issue is already available from QC in version AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.131 onwards.

Comment 5

5 years ago
Hi! 

When is this version supposed to reach the users?Asking as I am using a commercial ZTE device from TEF Spain (V1.01.00.01.019.120). I see the same issue with tel loosing data connection when it goes idle.

Thanks,
Hermina
Hi, 

By my understanding, I think this should be available in 1.1, but not before. Unless we'd face an extremely critical issue it's difficult to release a new build via OTA, as we should certificate it again. 

Thks!
David
some work is ongoing in bug 909688, I'm going to dupe this bug then :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909688
You need to log in before you can comment on or make changes to this bug.