Closed Bug 895174 Opened 7 years ago Closed 7 years ago

defect - not able to scroll list of recent history in snap view

Categories

(Firefox for Metro Graveyard :: General, defect, P2)

x86
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jbecerra, Assigned: rsilveira)

References

Details

(Whiteboard: DUPEME feature=defect c=tbd u=tbd p=1)

Attachments

(1 file, 1 obsolete file)

Tested on 2013-07-17 using latest nightly.

While testing bug 886584 I noticed that you can't scroll vertically in the list of Recent History items.

Steps:
1. Open Firefox Metro (make sure you have several items in the recent history)
2. Put Firefox in snap view
3. Select Recent History (notice the item at the bottom might be cut off)
4. Try to scroll down the list

Expected: You can scroll down the list

Actual: You can't scroll down the list.

More often than not I find myself trying to scroll down the list, because that seems natural.
Whiteboard: DUPEME → DUPEME feature=defect c=tbd u=tbd p=0
Attached patch Patch v1 (obsolete) — Splinter Review
This patch will handle mouse wheel scroll in snapped. At least with bug 892046 touch is working too - but it will select a tile if touch start on a tile, we will need to adjust that.
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
Attachment #778712 - Flags: review?(mbrubeck)
Hey Rodrigo, can you provide a point estimate?
Blocks: metrov1it11
No longer blocks: metrov1defect&change
Flags: needinfo?(rsilveira)
Priority: -- → P2
QA Contact: jbecerra
p=1
Flags: needinfo?(rsilveira)
Whiteboard: DUPEME feature=defect c=tbd u=tbd p=0 → DUPEME feature=defect c=tbd u=tbd p=1
Comment on attachment 778712 [details] [diff] [review]
Patch v1

Review of attachment 778712 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/content/browser-ui.js
@@ +1200,5 @@
>        case "MozMousePixelScroll":
>          let startBox = document.getElementById("start-scrollbox");
>          let [, scrollInterface] = ScrollUtils.getScrollboxFromElement(startBox);
>  
> +        if (MetroUtils.snappedState == Ci.nsIWinMetroUtils.snapped) {

I think that MetroUtils.snappedState might go away soon with bug 892512 and bug 891056... but we can change this line if and when it does.
Attachment #778712 - Flags: review?(mbrubeck) → review+
Attached patch Patch v2Splinter Review
Actually Ci.nsIWinMetroUtils was throwing in -metrodesktop mode, switching to viewstate instead.
Attachment #778712 - Attachment is obsolete: true
Attachment #779313 - Flags: review?(mbrubeck)
Attachment #779313 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/ac9174e8ed06
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Win 8 64bit - latest Nightly - Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130729 Firefox/25.0

Win 8 32bit - latest Nightly - Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130728 Firefox/25.0

With both builds, I can still reproduce the issue mentioned in the description. I can't scroll down the list. All I can see are 14 items in the Recent History list.
Verified as fixed, for iteration #15, with both Win 8 32-bit and 64-bit, using latest Nightly (build ID: 20131006030201) and the STR from comment 0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.