get packaged app tests working on Android

RESOLVED DUPLICATE of bug 873567

Status

()

RESOLVED DUPLICATE of bug 873567
6 years ago
6 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
Now that Fennec supports packaged apps, we should get the packaged app tests in dom/apps/tests/ working on it.

Currently, when I run all the tests in that directory, the packaged app tests get stuck and time out:

--------------------------------------------------------------------------------
07-17 18:29 > TEST_PATH=dom/apps/tests make -C objdir-droid/ mochitest-remote
…
74 INFO TEST-START | /tests/dom/apps/tests/test_packaged_app_install.html
75 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Set up
76 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | autoConfirmAppInstall
77 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | setAppVersion OK
78 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == Network error
79 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Got expected NETWORK_ERROR
80 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == Not valid mini-manifest content type
81 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Got expected INVALID_MANIFEST
82 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == Size value is not a number
83 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Got expected INVALID_MANIFEST
84 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == Negative size value
85 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Got expected INVALID_MANIFEST
86 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == Installing app with wrong package path
87 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | Got expected INVALID_MANIFEST
88 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | == TEST == No manifest in the zip file
89 INFO TEST-PASS | /tests/dom/apps/tests/test_packaged_app_install.html | App installed
90 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/apps/tests/test_packaged_app_install.html | Test timed out.
--------------------------------------------------------------------------------
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873567
You need to log in before you can comment on or make changes to this bug.