[Buri][fugu][BT]Select one picture to share by BT, you will find it flicker once

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Bluetooth
P1
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-, b2g18?)

Details

Attachments

(3 attachments)

17.34 KB, application/octet-stream
Details
17.34 KB, application/octet-stream
Details
22.88 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 DEFECT DESCRIPTION:
 Select one picture to share by BT,you will find it flicker once
 
 REPRODUCING PROCEDURES:
 1.turn off the BT
 2.tap gallery->select one picture to share by BT
 3.sometimes you will find flicker once,then display interface of BT->ko  
 
 EXPECTED BEHAVIOUR:
 it should display interface of BT immediately  
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 3/5
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 777634 [details]
Kernel log
(Reporter)

Comment 3

5 years ago
Created attachment 777639 [details]
Kernel log
(Reporter)

Comment 4

5 years ago
Clone from brother
(Reporter)

Comment 5

5 years ago
Created attachment 777640 [details]
logcat

Comment 6

5 years ago
Dear Liu,
As we all know, it's an user experience problem. But I think maybe we should solve bugs like this.
What do you think?
Flags: needinfo?(iliu)
It think I can reproduce this almost everytime. This should be a UX issue.
Also, need info from neo.
Flags: needinfo?(nhsieh)
The issue should be reproduced on v1-train only.

Since Bug 866174 - Use an icon/splashscreen for application cold launch is landed, we don't keep the screen shot for launching activity. So, we're not able to reproduce it on gaia/master after https://github.com/mozilla-b2g/gaia/commit/7f27d41a9202f9390c5e09475fe03fc7f3e77b83 .

It's not a blocking issue. So, I would not nominate it for ?+.
Depends on: 866174
Flags: needinfo?(iliu)
Summary: [Buri][BT]Select one picture to share by BT,you will find it flicker once → [Buri][BT]Select one picture to share by BT, you will find it flicker once
Hi Walter,

I think we can not produce it on gaia/master. So, we might comment UX for having a loading screen while activity is launching and switching to different page. But it will need some support from system app. And not sure we are able to implement it.
Since it is fixed in next version, this is solved already.

I will close it as resolved fixes since the patch is in master branch and it might be risky to uplift this patch (patch influenced lots of other areas). Next version patch would fix the issue.

Partner,
please let us know if you got other thoughts.
NeedInfo Xiaokang Chen for partner's opinion. We would like to fix the issue in next version. Please reference comment 8 and 10. Thanks.
Flags: needinfo?(chenxk)

Comment 12

5 years ago
What do you mean by 'next version'? If you means v1.2, can you mark this as koi?
Flags: needinfo?(chenxk)
Hi, Xiaokang,
This should not be a blocking issue. We would try to fix it next time.

However, per partner request to fix this. Kevin, can we nominate this as b2g18-tracking+ ?? Or any tracking flag suitable for this situation plz.
tracking-b2g18: --- → ?
Flags: needinfo?(khu)

Comment 14

4 years ago
thanks
Flags: needinfo?(nhsieh)

Comment 15

4 years ago
Can we fix it in v1.3?
Flags: needinfo?(khu)
I am referring to fix it in next version (v1.3).
I didn't nominate as a koi, but a tracking-b2g18.
I can do v1.3? also.
blocking-b2g: --- → 1.3?
Summary: [Buri][BT]Select one picture to share by BT, you will find it flicker once → [Buri][fugu][BT]Select one picture to share by BT, you will find it flicker once
Kevin

Is this fugu specific?
Flags: needinfo?(khu)
Actually see that it is on Buri as well.

Comment 19

4 years ago
I don't think this is a Fugu specific bug. This bug was reported couple months earlier.
Flags: needinfo?(khu)
(In reply to Kevin Hu [:khu] from comment #19)
> I don't think this is a Fugu specific bug. This bug was reported couple
> months earlier.
Yes, this issue is not relative with devices.
(In reply to Walter Chen[:ypwalter][:wachen] from comment #16)
> I am referring to fix it in next version (v1.3).
> I didn't nominate as a koi, but a tracking-b2g18.
> I can do v1.3? also.
Hi Walter,

Do you mean the issue is still reproduced in v1.3? I think bug 895290 is fixed, the issue should not be reproduced. And I am not able to reproduce it in v1.3.
Flags: needinfo?(wachen)
(In reply to Ian Liu [:ianliu] from comment #21)
> Do you mean the issue is still reproduced in v1.3? I think bug 895290 is
typo error ==> should be bug 866174.
> fixed, the issue should not be reproduced. And I am not able to reproduce it
> in v1.3.
My test is in build version:

Gaia  	588a3e02c4ace3b3341ba1f6bb7274120b53b2b3
Gecko 	http://hg.mozilla.org/releases/mozilla-aurora/rev/031270be3702
BuildID   20131212004003
Version   28.0a2
ro.build.version.incremental=eng.cltbld.20131212.040310
ro.build.date=Thu Dec 12 04:24:12 EST 2013
1.3-, this is old bug.  please ride the trains.
blocking-b2g: 1.3? → -
no reproducible. sry for very late reply
Flags: needinfo?(wachen)
I think we are able to close the issue for verification again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.