[Fugu][Buri][Musicplayer][Call]The music play interface display abnormal after hang up the call

RESOLVED FIXED

Status

Firefox OS
Gaia::Music
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: dkuo, NeedInfo)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:fugu+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 Created an attachment (id=464490)
 pic
 
 DEFECT DESCRIPTION:
 The music play interface display abnormal after hang up the call
 
 REPRODUCING PROCEDURES:
 1.plug in earphone
 2.Make a MT call to the test phone,then click the home key back to IDLE
 3.Enter Music -->select a song to play-->the song can paly ,but don't have sound-->KO1
 4.hang up the call,then the song play interface display abnormal-->KO2
 
 EXPECTED BEHAVIOUR:
 KO1:can't enter the music and to select a song to play
 KO2:The music paly interface should display normal
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:mid
 
 REPRODUCING RATE:5/5
 
 For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
Flags: needinfo?(alive)
Flags: needinfo?(akeybl)

Updated

5 years ago
blocking-b2g: --- → leo?
Uh, I cannot test call out now..what's the screenshot of KO2?
about KO1, are you saying you want to hear music when calling out?
Flags: needinfo?(alive)
ni? reporter for comment 1
Flags: needinfo?(akeybl) → needinfo?(sync-1)

Comment 3

5 years ago
Created attachment 779580 [details]
11.PNG

Comment 4

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #2)
> ni? reporter for comment 1

The screenshot of KO2 is like attachment 779580 [details].
About KO1, I think we should hear music like no earphone. Please make the same rule with earphone or no.
Flags: needinfo?(sync-1)
Dominic, could you check KO2? I think the music app is already resized correctly but maybe the background-image doesn't. Maybe listen to resize event to adjust it.

About KO1, I don't think we should play music as well as the voice call is ongoing. What's the need?
Flags: needinfo?(dkuo)

Comment 6

5 years ago
Not clear this is a regression or critical support issue, therefore not a blocker for 1.2.
blocking-b2g: leo? → -
(Assignee)

Comment 7

5 years ago
(In reply to Alive Kuo [:alive][Paris work week 7/22-26] from comment #5)
> Dominic, could you check KO2? I think the music app is already resized
> correctly but maybe the background-image doesn't. Maybe listen to resize
> event to adjust it.

I am able to reproduce KO2, I think it's because the album art used left and top to position, and music app didn't update it after resize, I will probably get rid of it and use background-size: cover instead.
Flags: needinfo?(dkuo)
(Assignee)

Updated

5 years ago
Assignee: nobody → dkuo
Summary: [Buri][Musicplayer][Call]The music play interface display abnormal after hang up the call → [Fugu][Buri][Musicplayer][Call]The music play interface display abnormal after hang up the call
blocking-b2g: - → koi?
Please determine if this is a cert blocker. Rather late for 1.2 so please provide the following details:
1) ETA of fix available
2) Risk analysis of fix
3) Why a blocker?
Flags: needinfo?(sync-1)
Flags: needinfo?(pcheng)
(In reply to Preeti Raghunath(:Preeti) from comment #8)
> Please determine if this is a cert blocker. Rather late for 1.2 so please
> provide the following details:
> 1) ETA of fix available
> 2) Risk analysis of fix
> 3) Why a blocker?

I've got a side email thread started trying to find out what's causing the general spike in fugu nominations.
Fugu cannot pass Spreadtrum's system tests due to these bugs, unless these bugs are either fixed or clarified won't-fix by their customer(telefonica). After discussion, we think it's better to mark these bugs as 'koi?' so they can start discussions with telefonica and everyone will be on the same page. 

Steven and I will have more discussion with Spreadtrum about nominating the blockers. Will update these bugs later.
Flags: needinfo?(pcheng)
Not a blocker - we already shipped 1.1 with this bug.
blocking-b2g: koi? → -
Dominic, are you still handling this issue?
Flags: needinfo?(dkuo)

Updated

4 years ago
blocking-b2g: - → fugu+
(Assignee)

Comment 13

4 years ago
(In reply to Steven Yang [:styang] from comment #12)
> Dominic, are you still handling this issue?

Currently no, but bug 943797 which I am working on should also solve this issue, that bug is under reviewing and has covered the approach I have mentioned in comment 7, we can wait bug 943797 to be landed first and see if it also fix this issue.
Depends on: 943797
Flags: needinfo?(dkuo)
(Assignee)

Comment 14

4 years ago
Bug 943797 is landed and should also fix this, so closing this bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.