Misread coordinate values in SVG path with hardware acceleration enabled

RESOLVED WORKSFORME

Status

()

Core
Graphics: Text
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: david.dailey, Unassigned)

Tracking

({regression})

15 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF; BRI/1; InfoPath.2; .NET4.0C; BRI/2; BOIE9;ENUSMSNIP)

Steps to reproduce:

http://cs.sru.edu/~ddailey/svg/alphabet.svg
It works as desired in Chrome, Safari, Opera and IE. 


Actual results:

I see no error in the FF error console, but note how the L parts of the paths on a,b,d extend below the 550 line. It doesn't do that in the other browsers; just FF.


Expected results:

It would be nice if all the browsers behaved the same. In this case FF does not behave as I would expect it to. Not sure why.

Comment 1

4 years ago
It's an issue with HWA (and Azure/Skia, I guess), not SVG.
Disabling HWA fixes the issue.

Regression range:
good=2012-05-23
bad=2012-05-24
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36e938e51481&tochange=f43e8d300f21

Suspected bug:
Nicholas Cameron — Bug 752380. Refactor gfxFont out of Azure. r=Bas
Blocks: 752380
Status: UNCONFIRMED → NEW
Component: SVG → Graphics: Text
Ever confirmed: true
Keywords: regression
Summary: Misread coordinate values in SVG path → Misread coordinate values in SVG path with hardware acceleration enabled
Version: 22 Branch → 15 Branch

Comment 2

4 years ago
Dupe Bug 854296 ?

Comment 3

4 years ago
It sounds like, but the reporter of bug 854296 said some cases are not fixed with HWA off. Let's this one open for a while.
Does this still reproduce in the current Firefox Nightly?
Has Regression Range: --- → yes
Flags: needinfo?(david.dailey)
(Reporter)

Comment 5

a year ago
Wow. I have no recollection of what this was. All I can say is that
a) The original example now renders the same for me in Chrome, Firefox and IE (It seems that Opera sort of died, or became irrelevant since then, folding their tents into the Chrome knapsack -- a terrible shame). My Firefox now is 48.0 (don't know if that is what ya'll call nightly or not).
b) any relationship to hardware acceleration seems more related to this:
https://bugzilla.mozilla.org/show_bug.cgi?id=1293134 following from the browser hang at
https://ello.co/ddailey/post/hwqd8hmolnwx7-vp4zocfq
That bug, following some (rather magical seeming, to me) diagnostics involving turning things off and on (and using Safe Mode and such) resulted in the bug (as I understand it, being transformed into another HWA bug related to blend modes and HWA in FF for Windows.

So far as I can tell, any problems associated with rendering the original page (http://cs.sru.edu/~ddailey/svg/alphabet.svg) have gone away. I think I must have been trying to make an alphabet that could reuse a minimal number of subglyphs. 

Let me know if I can provide more info.

Comment 6

a year ago
As the primary issue about rendering SVg is fixed, let's close this bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(david.dailey)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.