Closed Bug 895524 Opened 8 years ago Closed 7 years ago

[B2G][l10n][First Time Experience] Korean: translation of "Change" is not completly shown in Date & Time

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S3 (14mar)
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: jincreator, Assigned: flod)

References

Details

(Keywords: l12y)

Attachments

(3 files, 1 obsolete file)

Attached image Korean ftu screen in
"Change" is translated into "바꾸기" - 3 letters.
But ftu is only showing "바꾸" - 2 letters.
However, ftu can show entire English word "Change" - 6 letters.

I attached screenshot and I think you can find out only 2 Korean letters are shown even you can't read Korean.
Blocks: 892075
Keywords: l12y
QA Contact: channy
I see the current string is 2 characters long, I guess the Korean team changed it to make the text fit
https://hg.mozilla.org/gaia-l10n/ko/file/017d2f417759/apps/communications/ftu/ftu.properties#l164
change = 변경

I'm trying with devtools and app manager to fit "바꾸기", but only "바꾸" is displayed. This on the current master.

Width of this element is set to 8rem (I don't think we can change that, because of very long city names)
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/ftu/css/style.css#L630

And a padding-right of 3em inherited from buttons
https://github.com/mozilla-b2g/gaia/blob/master/shared/style/buttons.css#L160

What's strange is that I can put "verylongchange" in there, but "long change" gets wrapped, so it's related to white spaces.

So, adding white-spaces: nowrap; to .change should be enough.

Flagging Borja for an opinion, since he helped fixing another CSS issue in FTU before.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(borja.bugzilla)
Attached image Screenshot Keon (obsolete) —
Screenshot with whitespaces: nowrap; added to .change
Attached file Pull request on Github
I realized I can change this in FTE without touching /shared, so it seems pretty safe. No change for existing locales, just fixes some edge cases like Korean.
Attachment #8390360 - Flags: review?(fernando.campo)
Flags: needinfo?(borja.bugzilla)
Attached image Screenshot on Keon
Screenshot on Keon with the patch applied: FTE set to Korean, text changed to "바꾸기".
Assignee: nobody → francesco.lodolo
Attachment #8389054 - Attachment is obsolete: true
(In reply to Francesco Lodolo [:flod] from comment #3)
> I realized I can change this in FTE without touching /shared, so it seems
> pretty safe. No change for existing locales, just fixes some edge cases like
> Korean.

Okay. That's good job!
Comment on attachment 8390360 [details] [review]
Pull request on Github

I'd say to add tests, but honestly, no idea how to test that a button content shows all the text inside of the space it has :S

Thanks for the super short fix!
Attachment #8390360 - Flags: review?(fernando.campo) → review+
Thanks for the review.

(In reply to Fernando Campo (:fcampo) from comment #6)
> I'd say to add tests, but honestly, no idea how to test that a button
> content shows all the text inside of the space it has :S

Even if that's possible, not sure how we could do that with all localizations we ship (it would be great, basically automated QA, but I don't see that happening).

Setting keyword for checkin.
Keywords: checkin-needed
Master: fba11cf6ae2a5d5e1cc7f71dfe01eed734281c42
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
You need to log in before you can comment on or make changes to this bug.