If browser is in fullscreen, exiting fullscreen HTML5 video will cause the browser to exit fullscreen

RESOLVED DUPLICATE of bug 947854

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 947854
5 years ago
3 years ago

People

(Reporter: megaminxwin, Unassigned)

Tracking

22 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. I put Firefox into fullscreen mode.

2. I started playing HTML5 video in fullscreen.

3. I exited the HTML5 video fullscreen mode.


Actual results:

The whole browser exited fullscreen, instead of just the HTML5 video itself.


Expected results:

The HTML5 video should exit while leaving the fullscreen browser mode intact.

Comment 1

5 years ago
CC'ing cpearce who works on similar bug 724554.
Component: Untriaged → General
Flags: needinfo?(cpearce)
Summary: If browser is in fullscreen on Mac, exiting fullscreen HTML5 video will cause the browser to exit fullscreen → If browser is in fullscreen, exiting fullscreen HTML5 video will cause the browser to exit fullscreen
Thanks for filing this bug. It's a known issue, which we should fix sometime.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(cpearce)
Resolution: --- → DUPLICATE
Duplicate of bug: 807395
You need to log in before you can comment on or make changes to this bug.