Intermittent browser_privatebrowsing_urlbarfocus.js | URL Bar should not be empty after opening window - Didn't expect , but got it

RESOLVED FIXED in Firefox 24

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: RyanVM, Assigned: ttaubert)

Tracking

({intermittent-failure})

Trunk
Firefox 26
x86_64
macOS
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

Details

(Reporter)

Description

6 years ago
Smaug, I can't help but notice that you recently had to modify this test for the snow-white landing.

https://tbpl.mozilla.org/php/getParsedLog.php?id=25447268&tree=Mozilla-Inbound

Rev4 MacOSX Lion 10.7 mozilla-inbound debug test mochitest-browser-chrome on 2013-07-18 10:39:20 PDT for push df2ffeb51fc0
slave: talos-r4-lion-025

11:00:17     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Console message: OpenGL LayerManager Initialized Succesfully.
11:00:17     INFO -  Version: 2.1 NVIDIA-7.12.9
11:00:17     INFO -  Vendor: NVIDIA Corporation
11:00:17     INFO -  Renderer: NVIDIA GeForce 320M OpenGL Engine
11:00:17     INFO -  FBO Texture Target: TEXTURE_2D
11:00:17     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266
11:00:17     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Got load
11:00:17     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Got activate.
11:00:18     INFO -  WARNING: NS_ENSURE_TRUE(mTextInputHandler) failed: file ../../../widget/cocoa/nsChildView.mm, line 5109
11:00:18     INFO -  JavaScript strict warning: chrome://browser/content/urlbarBindings.xml, line 672: reference to undefined property this._value
11:00:18     INFO -  JavaScript error: chrome://browser/content/urlbarBindings.xml, line 654: aUrl is undefined
11:00:18     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Console message: [JavaScript Warning: "ReferenceError: reference to undefined property this._value" {file: "chrome://browser/content/urlbarBindings.xml" line: 672}]
11:00:18     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Console message: [JavaScript Error: "TypeError: aUrl is undefined" {file: "chrome://browser/content/urlbarBindings.xml" line: 654}]
11:00:18     INFO -  ++DOMWINDOW == 107 (0x150385308) [serial = 3858] [outer = 0x15cb92ee8]
11:00:18     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | Console message: [JavaScript Error: "The character encoding of the plain text document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the file needs to be declared in the transfer protocol or file needs to use a byte order mark as an encoding signature." {file: "data:text/plain,test" line: 0}]
11:00:18     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | URL Bar should not be focused after opening window
11:00:18  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | URL Bar should not be empty after opening window - Didn't expect , but got it
11:00:18     INFO -  Stack trace:
11:00:18     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_isnot :: line 540
11:00:18     INFO -      JS frame :: chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js :: checkUrlbarFocus :: line 23
11:00:18     INFO -      JS frame :: chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js :: test/</</</</< :: line 64
11:00:18     INFO -      JS frame :: chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js :: test/whenLoadTab/</< :: line 49
11:00:18     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
11:00:18     INFO -  --DOCSHELL 0x15ca86b00 == 22 [id = 1393]
11:00:18     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_urlbarfocus.js | finished in 8080ms
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I assume this is caused by the same issue as bug 880101 and should be fixed soon.
Depends on: 880101
Marking as (hopefully) fixed by bug 880101.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Assignee: nobody → ttaubert
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → fixed
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.