Closed Bug 895962 Opened 7 years ago Closed 7 years ago

defect - find bar not dismissed with CTRL-L

Categories

(Firefox for Metro Graveyard :: Browser, defect, P2)

All
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jbecerra, Assigned: mbrubeck)

References

Details

(Whiteboard: DUPEME feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=1)

Attachments

(1 file)

Tested on 2013-07-19 using latest nightly while doing regression testing for story in bug 867641.

I noticed that after having brought up and used the find bar, it wasn't dismissed when I then used the hardware keyboard to focus on the URL bar.

Steps:
1. Go to www.google.com
2. Swipe from the bottom to bring up the navigation app bar
3. Tap on the settings and select Find in Page
4. Type "google" and tap any of the arrows to cycle through the results
5. Using the hardware keyboard press ctrl-L

Expected: Find bar is dismissed and you can see the navigation bar where you can type a URL.

Actual: Find in bar is visible, and behind it you can see what should be the top navigation bar.
Whiteboard: DUPEME → DUPEME feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=0
Assignee: nobody → mbrubeck
Whiteboard: DUPEME feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=0 → DUPEME feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=1
Blocks: metrov1it11
No longer blocks: metrov1defect&change
Priority: -- → P2
QA Contact: jbecerra
Status: NEW → ASSIGNED
Attached patch find-blurSplinter Review
We previously fixed this (bug 771255) in appbar.js but that code has been removed:
https://hg.mozilla.org/users/mbrubeck_mozilla.com/elm-metro-firefox/rev/0867537267f6

There's also code that does this on MozContextUIShow, but that event is no longer what we want, and in fact we no longer have any use for the MozContextUIShow or Dismiss events.  This patch removes them and uses MozAppbarShowing instead.

Also adds a test for this bug, and changes some errant tabs to spaces.
Attachment #778596 - Flags: review?(rsilveira)
Component: General → Browser
Flags: in-testsuite+
OS: Mac OS X → Windows 8 Metro
Hardware: x86 → All
Comment on attachment 778596 [details] [diff] [review]
find-blur

Review of attachment 778596 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great.

::: browser/metro/base/content/helperui/FindHelperUI.js
@@ +56,5 @@
>  
>      // Listen for events where form assistant should be closed
>      Elements.tabList.addEventListener("TabSelect", this, true);
>      Elements.browsers.addEventListener("URLChanged", this, true);
> +    window.addEventListener('MozAppbarShowing', this);

Nit: use double quotes for consistency of change the other to single.
Attachment #778596 - Flags: review?(rsilveira) → review+
https://hg.mozilla.org/mozilla-central/rev/ed1a14f6ef85
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130728 Firefox/25.0

Verified as fixed on the latest Nightly build (on desktop) using the steps from the description. Find bar dismissed with CTRL-L.

This still needs verification for mobile devices.
Status: RESOLVED → VERIFIED
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130826074752
Built from http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.