Closed Bug 895994 Opened 6 years ago Closed 6 years ago

[B2G][Contacts][Leo] User is unable to add or import contacts

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
blocking-b2g leo+
Tracking Status
firefox23 --- wontfix
firefox24 --- wontfix
firefox25 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: ndavidson, Assigned: reuben)

References

Details

(Keywords: regression, smoketest, Whiteboard: [fixed-in-birch])

Attachments

(3 files)

Description: When user is trying to save a new contact by pressing "Done" button in upper right corner, button becomes grayed-out but contact is not saved.
If user exits out, by pressing the Home button and comes back to the contacts app, contacts are not saved.

Repro Steps:
1) Updated Leo to Build ID: 20130719070225
2) Tap in a Contacts button.
3) Tap on a "plus" button to enter new contacts details
4) Enter information in first/last name phone number fields (other fields are optional)
5) Tap on the "done" button to save contact

Actual:
"Done" button becomes grayed-out and contact is not saved in contacts app.

Expected:
Contact is saved on the device.

Environmental Variables
Build ID: 20130719070225
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6b6e80e9aaf0
Gaia: ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
Platform Version: 18.1
RIL Version: 01.01.00.019.164 

Notes:
Repro frequency: 100%
Q Analysts Team Priority: Pri Levels: Pri 1
See attached: screenshot, logcat, 
Optional extra notes:
This is a high impact bug for contacts. Request escalation to Pr 1
blocking-b2g: --- → leo?
I can reproduce this on a freshly flashed Leo device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/6b6e80e9aaf0
Gaia   ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
BuildID 20130719070225
Version 18.1

But on the phone that I did on OTA on, I cannot.  

Will need a regression window for this bug as well.
Leo device, works:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/7f6f4bc1a621
Gaia   f1d2e3fd806dc55f167c72ac8ef7a3b6baed915e
BuildID 20130718070206
Version 18.1

Broken:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b11cbde4f5f1
Gaia   4abea646d93973d1d0bfae7f82783655cd5ea393
BuildID 20130718230225
Version 18.1
Only potential regression candidate that could have caused this that I'm seeing is bug 892497. Reuben is looking into this right now.
Blocks: 892497
I can't import contacts from Facebook or Gmail either - so basically the Contacts app is unusable in this build.
Summary: [B2G][Contacts] User is unable to save contact by pressing "Done" button → [B2G][Contacts] User is unable to add or import contacts
Component: Gaia::Contacts → DOM: Device Interfaces
Product: Boot2Gecko → Core
Version: unspecified → Trunk
Talking with Reuben over IRC, this sounds like a bad b2g18-specific patch of bug 892497.
Update for the bug readers - this might be a RIL-specific issue. This does not reproduce on the Mozilla RIL, but reproduces on the commercial RIL.
Using a Leo Mozilla RIL build, fresh flash, I cannot reproduce this issue:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/6b6e80e9aaf0
Gaia   ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
BuildID 20130719070225
Version 18.1

This also does work on an equivalent Unagi nightly build.
Summary: [B2G][Contacts] User is unable to add or import contacts → [B2G][Contacts][Leo] User is unable to add or import contacts using the Commercial RIL
Something very weird is going on here. It seems we're failing during or shortly after upgrading the DB, and whenever we try to load the contacts list or save a contact, we run the upgrade again.
This isn't a RIL specific issue.  If you remove the RIL as seen from https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Dealing_with_the_Commercial_RIL, you will find that the issue still reproduces.
Summary: [B2G][Contacts][Leo] User is unable to add or import contacts using the Commercial RIL → [B2G][Contacts][Leo] User is unable to add or import contacts
There is a chance that bug 896786 may resolve this issue?
Marcia, I can't reproduce this bug after flashing an updated build over the weekend. Does it still reproduce for you?
Flags: needinfo?(mozillamarcia.knous)
If it still reproduces I would like to get a phone that shows the issue in SF.
(In reply to Gregor Wagner [:gwagner] from comment #14)
> If it still reproduces I would like to get a phone that shows the issue in
> SF.

I'll be up in SF on Wed - Fri this week. Let me see if I can borrow one of the phones Marcia reproduced this on to show you this bug.
I gave Jason the Leo phone I have that reproduced it, which is running the build from Comment 0. Note that I am getting inconsistent results as I have another device with the same base build and build ID which does not exhibit the bug, and as Reuben notes in Comment 13 sometimes with a fresh flash it works.

I can also reproduce the bug using Leo device with the newest base image running:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia   c376446da64aacb6907b26542a2684d54a0162eb
BuildID 20130722230203
Version 18.1
Flags: needinfo?(mozillamarcia.knous)
If we know this is caused by bug 892497, can we back that out?

I think I pushed for blocking on that bug due to dataloss risk, but without more data about how bad it is, we should reconsider cost vs benefit for 1.1 because this type of regression puts the 1.1 schedule at risk.
ni? gwagner for comment 17
Flags: needinfo?(anygregor)
I think we figured it out. Reuben is currently writing a patch.
Assignee: nobody → reuben.bmo
Flags: needinfo?(anygregor)
Comment on attachment 781330 [details] [diff] [review]
Add missing .bind(this)

Review of attachment 781330 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #781330 - Flags: review+
So this is not device specific. It only showed up when people had a json file with default contacts.
(And the leo builds have default contacts)
blocking-b2g: leo? → leo+
https://hg.mozilla.org/mozilla-central/rev/6adaf0424d61
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Issue no longe repro on Leo v1.1 Build ID: 20130726070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d6e518d3ef28
Gaia: 9c868050bcc6f522f54f4afc0f0e4aa9a6149771
Platform Version: 18.1
RIL Version: 01.01.00.019.171 
User is now able to add new contacts or import contacts from email or Facebook
You need to log in before you can comment on or make changes to this bug.