screen goes off after reset and before FTU starts while power-on video is playing

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::System
P1
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
1.1 QE5
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

Details

(Whiteboard: [LeoVB+])

Attachments

(2 attachments)

8.78 MB, application/octet-stream
alive
: feedback+
Details
198 bytes, text/plain
alive
: review+
Details
(Reporter)

Description

4 years ago
After resetting a device, the screen goes off before FTU starts while power-on video is playing.

Steps to repro:
1. Reset device.
2. The device starts up showing Firefox logo and power-on video.
3. Observe the device suddenly turn off the screen.

Repro frequency: 50% (for the power-on video I have, 3 seconds video)


With v1-train, this is not reproduced because it doesn't have a power-on video.

From my analysis, the issue is in _reconfigScreenTimeout function of screen_manager.js
"this._setIdleTimeout(10, true);" is called when the power-on video plays because LockScreen.locked is true by default. And if the startup process (including playing the power-on video) takes longer than 10, the screen will go off.

Please refer to attachment video.


My solution is to call the "this._setIdleTimeout(0);" when WindowManager.getDisplayedApp() is null, meaning no app has been displayed yet. It works fine with this fix.

    if (this._screenWakeLocked || !WindowManager.getDisplayedApp()) {
      console.log('sssss _reconfigScreenTimeout checkpoint 1');
      this._setIdleTimeout(0);
    } else if (LockScreen.locked) {

Is this fix acceptable?
(Reporter)

Updated

4 years ago
Severity: normal → blocker
blocking-b2g: --- → leo+
Priority: -- → P1
Target Milestone: --- → 1.1 QE5

Comment 1

4 years ago
Created attachment 779051 [details]
Repro video

I have hidden the center of power-on video, please ignore the content of video. It just looks like white screen.

00:07 The power-on video starts.
00:20 All of a sudden, the screen goes off.
Attachment #779051 - Flags: feedback?(alive)
Comment on attachment 779051 [details]
Repro video

I cannot think of anything harmful now.
BTW please send a patch.
Attachment #779051 - Flags: feedback?(alive) → feedback+

Comment 3

4 years ago
Created attachment 779595 [details]
Pull request url

Please also uplift to v1-train.
Attachment #779595 - Flags: review?(alive)
(Reporter)

Updated

4 years ago
Whiteboard: [LeoVB+]
Comment on attachment 779595 [details]
Pull request url

Line 388, E:0110: Line too long (93 characters).
Please correct this.
Attachment #779595 - Flags: review?(alive) → review+

Comment 5

4 years ago
(In reply to Alive Kuo [:alive][Paris work week 7/22-26] from comment #4)

Corrected. Thanks!
master

https://github.com/mozilla-b2g/gaia/commit/7eea78d212799ebbde7f4b78a05973b397c0b6d4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g18: --- → affected
Resolution: --- → FIXED
Uplifted 7eea78d212799ebbde7f4b78a05973b397c0b6d4 to:
v1-train: 8618b29382f2d8bc2809eab970ff059a2869be17
status-b2g18: affected → fixed

Comment 8

4 years ago
Verified fixed on 

Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1

The screen does not power off after reset or before the FTU starts
status-b2g18: fixed → verified
v1.1.0hd: 8618b29382f2d8bc2809eab970ff059a2869be17
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.