[Facebook] User cannot navigate back after selecting to play particular videos.

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3rd Party][apps watch list1])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 779053 [details]
Player view where user cannot navigate back

STR:
  1. Open facebook application and try opening video files hosted in 
     facebook(not youtube or other servers)
  2. Video will be opened in a new screen.

Expected:
  There should be option for user to close the video and come back to the application.

Actual:
  Once a video is selected, the user has to kill the application to close the view.

The attachment shows the kind of video selected and the view in which video will be played. Videos hosted on youtube doesn't provide this problem.
Flags: needinfo?(jsmith)
Flags: needinfo?(hkirschner)
That video being referenced - is that a link to a video? A video attachment? I'm having trouble trying to figure out the exact STR. I just tried this on my test account with a mp4 video uploaded and couldn't get the STR seen here.
Flags: needinfo?(jsmith)

Updated

5 years ago
Blocks: 869192
(Reporter)

Comment 2

5 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> That video being referenced - is that a link to a video? A video attachment?
> I'm having trouble trying to figure out the exact STR. I just tried this on
> my test account with a mp4 video uploaded and couldn't get the STR seen here.

Sorry jason, even i couldn't find out what kind of video is that. May be you could try to find video's shown like the 1st image in the screenshot.
I also tried reproducing without luck? Any more details on the video type, Leo?
Flags: needinfo?(hkirschner) → needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 4

5 years ago
Created attachment 789352 [details]
screen shot of video from facebook page

Finally i was able to get some details about the video.

STR:
  1. Search for "Video Inspiration" page in facebook and open the page.
  2. Open and play videos shared in this page.

Hope this is helpful to reproduce the issue. Please let me know if you can reproduce the issue with these STR.
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(jsmith)
Flags: needinfo?(hkirschner)
I can confirm the STR you have reproduces the bug here. Looks like the video renders off the origin of the app as well.

There are two ways we could solve this problem:

1. Have Facebook implement the chrome navigation property to have a back button present during usage of the app
2. Implement support for a back button on fullscreen video viewing

[1] is likely more feasible to pull off and needs to be done anyways due to other problems, so let's do that here.
Flags: needinfo?(jsmith)
Notified partner, will update as it progresses.
Flags: needinfo?(hkirschner)
Facebook added "chrome" to their manifest, this fixes this bug for leo.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Blocks: 916311

Updated

5 years ago
No longer blocks: 916311
You need to log in before you can comment on or make changes to this bug.