Closed Bug 896407 Opened 7 years ago Closed 7 years ago

[Buri][Bluetooth]There is no any reminding on lock screen when other device sends the pairing request.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1)

defect

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 859168
blocking-b2g -

People

(Reporter: sync-1, Unassigned)

Details

(Whiteboard: [enhancement])

Attachments

(1 file)

52.40 KB, application/octet-stream
Details
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.158
 Firefox os  v1.1
 Mozilla build ID:20130709070206
 
 DEFECT DESCRIPTION:
 There is no any reminding on lock screen when other device sends the pairing request.
 
 REPRODUCING PROCEDURES:
 1)turn on bluetooth of both test phone and device A;
 2)A searchs and initiates a pairing request to test phone->test phone accept and they shoud pair succesfully;
 3)unpair each other->press power key to lock the screen on test phone;
 4)device A initiates a pairing request to test phone->test phone has no any reminding;--->KO
 
 
 EXPECTED BEHAVIOUR:
 KO:test phone should have something prompt for users on lock screen;
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 Moderate
 
 REPRODUCING RATE:
 5/5
 
 For FT PR, Please list reference mobile's behavior:
blocking-b2g: --- → leo?
Dear evelyn,
Could you have a look at this? Thanks a lot !
Flags: needinfo?(ehung)
Clone from brother
It's by design. Our UX team think a pairing request isn't so urgent that have to show on lockscreen. So we filter this case out: https://github.com/mozilla-b2g/gaia/blob/v1.1.0hd/apps/settings/js/bluetooth.js#L698

      var req = navigator.mozSettings.createLock().get('lockscreen.locked');
      req.onsuccess = function bt_onGetLocksuccess() {
        if (!req.result['lockscreen.locked']) {
          showPairView();
        }
      };
      req.onerror = function bt_onGetLockError() {
        // fallback to default value 'unlocked'
        showPairView();
      };
    }

Same behavior on some Android phones.
Flags: needinfo?(ehung)
By design, so this is an enhancement request.
blocking-b2g: leo? → -
Whiteboard: [enhancement]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859168
You need to log in before you can comment on or make changes to this bug.