Defect - Firefox logo showing up in Top Sites tiles

RESOLVED FIXED in Firefox 25

Status

Firefox for Metro
Firefox Start
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jimm, Assigned: sfoster)

Tracking

Trunk
Firefox 25
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=tbd u=tbd p=2)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 779185 [details]
Screenshot (57).png

From a build off tip this morning. Looks like a bug.
(Assignee)

Comment 1

5 years ago
I'm seeing 0 background thumbnails as well as of this morning. (the firefox watermark is the default thumbnail used when we fail to get a screenshot thumbnail for whatever reason)

Not sure if this is fall-out from bug 892632 (shouldn't be, I tested that pretty thoroughly) or maybe bug 870100 or something nearby.

Updated

5 years ago
Summary: Firefox logo showing up in Top Sites tiles → Defect - Firefox logo showing up in Top Sites tiles
Whiteboard: feature=defect c=tbd u=tbd p=0

Updated

5 years ago
Assignee: nobody → sfoster
Blocks: 886790
No longer blocks: 859003
Status: NEW → ASSIGNED
QA Contact: jbecerra
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=2

Updated

5 years ago
Priority: -- → P2
(Assignee)

Comment 2

5 years ago
Created attachment 780474 [details] [diff] [review]
Fix lazy-loading of OS.File module

I tracked this down finally to a typo in browser-scripts where we import the osfile.jsm module that gives us OS.File.exists.
Attachment #780474 - Flags: review?(jmathies)
(Assignee)

Updated

5 years ago
Attachment #780474 - Attachment is patch: true
Attachment #780474 - Attachment mime type: message/rfc822 → text/plain
(Reporter)

Updated

5 years ago
Attachment #780474 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/7b72f5bd90d0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
(Reporter)

Updated

5 years ago
Duplicate of this bug: 897876
Created attachment 782546 [details]
screenshot_Nightly_2013-07-29

with the latest Nightly: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130729 Firefox/25.0

This issue isn't totally solved. For example, for Facebook and Vimeo, the Firefox logo is still showing up in Top Sites tiles.

Please see the attached screenshot for details.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.