Status

()

defect
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: rexyrexy2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Opened UX.


Actual results:

there was NO add-on/navigation bar. MAJOR usability downgrade. checked right click, about:config, options. it wasn't in any of them (or an option to enable it at the price of disabling new customization).


Expected results:

it should be there, or there should be an about:config entry for it, and an about:config entry for enable/disable of the old or new customization ui.
Version: 22 Branch → 25 Branch
Severity: normal → major
Priority: -- → P4
Component: Untriaged → Menus
Severity: major → critical
Priority: P4 → P5
This really needs to be fixed as it is a MAJOR downgrade.
*to not have it*
This was intentionally removed in bug 749804. You can now put lesser used extensions in the menu panel to avoid clutter. I don't have a pointer handy for the rationale but the UX team should be blogging about design decisions like this shortly.
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: Menus → Toolbars and Customization
Priority: P5 → --
Resolution: --- → INVALID
Version: 25 Branch → unspecified
Duplicate of this bug: 940112
Rant alert. Rant alert. Leave now if you can't face the truth.
<rant>
That FREAKING panel is NO replacement for the add-on bar. I don't care WHAT they say! 1. I need an extra click. 2. The items in there are HUGE, so it EASILY gets cluttered, making it harder to find what you need. 3. what if you need something that is a GADGET/WIDGET!??!?!??!?!?? then CONGRATULATIONS! YOU'RE OFFICIALLY SCREWED!!! WHY does everyone want to DESTROY their browser!? first Firefox, then opera! 
</rant>
Sorry for my rant, but you guys need to see that you are DESTROYING Firefox by
1. removing custom toolbar support (WHY!? That's a known feature that MANY companies/developers use on IE and FF (and on opera(Not chropera)))
2. Removing the add-on bar. (see rant above)
3. (minor) Removing the ability to remove the navigation bar.
All three of those things seem pointless other than for self destruction, or laziness. The last seems half reasonable in a way, but the other two are completely pointless.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.