Dynamic toolbar causes scroll events to be fired repeatedly

VERIFIED FIXED in Firefox 25

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: botond, Assigned: kats)

Tracking

({regression})

Trunk
Firefox 26
All
Android
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 verified, firefox26 verified, fennec25+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
To reproduce, open http://people.mozilla.org/~bballo/plain.html (plain HTML page with a wide image), with the dynamic toolbar enabled. The scrollbar on the right flickers repeatedly.

It looks like a scroll event is being fired repeatedly, which shouldn't be happening.
Blocks: 716403
tracking-fennec: --- → ?
This is a more recent regression than the original dynamic toolbar code. It only happens on nightly.
No longer blocks: 716403
status-firefox24: --- → unaffected
status-firefox25: --- → affected
The regression window is:
1. mozilla-central:
good build: 11.07.2013 
bad build:  12.07.2013 
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dde4dcd6fa46&tochange=b44898282f21

2. inbound:
good build: 1373557796
bad build:  1373562059 
-pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=df4cc5d63c7d&tochange=9e018ae9cbed
Thanks.
Blocks: 877602
Keywords: regressionwindow-wanted
Note that this still doesn't happen on aurora or beta, so it must be caused by the second (refactoring) patch on bug 877602 which was not uplifted.
Assignee: nobody → bugmail.mozilla
tracking-fennec: ? → 25+

Updated

5 years ago
Blocks: 716403
status-firefox26: --- → affected

Comment 6

5 years ago
Comment on attachment 788960 [details] [diff] [review]
Patch

Review of attachment 788960 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, I guess. Sorry to have roped you into this :)

::: mobile/android/chrome/content/browser.js
@@ +3916,5 @@
> +
> +    // Store the page size that was used to calculate the viewport so that we
> +    // can verify it's changed when we consider remeasuring in updateViewportForPageSize
> +    let viewport = this.getViewport();
> +    this.lastPageSizeUsedForViewportChange = {

Maybe this should be renamed lastPageSizeAfterViewportRemeasure, perhaps? It doesn't feel like this comment really corresponds to what's actually happening anymore...
Attachment #788960 - Flags: review?(chrislord.net) → review+
I updated the variable name as you suggested. The comment still made sense to me so I left it.

https://hg.mozilla.org/integration/fx-team/rev/ec6710da612e
https://hg.mozilla.org/mozilla-central/rev/ec6710da612e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
status-firefox26: affected → fixed
Comment on attachment 788960 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 877602 (second patch)
User impact if declined: on some pages the code will continue doing layouts infinitely, which is bad for battery life. also the scrollbars will keep flashing.
Testing completed (on m-c, etc.): locally; this should bake on m-c for a few days to ensure there's no other fallout
Risk to taking this patch (and alternatives if risky): low risk, fennec-only code
String or IDL/UUID changes made by this patch: none
Attachment #788960 - Flags: approval-mozilla-aurora?
Verified fixed on:
Build: Firefox for Android 26.0a1 (2013-08-13)
Device: HTC Desire HD
OS: Android 2.3.5
status-firefox26: fixed → verified

Updated

5 years ago
Attachment #788960 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 25.0a2 (2013-08-27)
Device: HTC Desire HD
OS: Android 2.3.5
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
You need to log in before you can comment on or make changes to this bug.