Closed Bug 896756 Opened 7 years ago Closed 7 years ago

Fix strict warnings in xpcshell's head.js

Categories

(Testing :: XPCShell Harness, defect)

defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed)

RESOLVED FIXED
mozilla25
Tracking Status
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Fix v1 (obsolete) — Splinter Review
There's a couple of strict warnings in head.js that are causing issues on comm-central. They are easy to fix with little risk, so we should just fix them.
Attachment #779458 - Flags: review?(ted)
Blocks: 896738
Duplicate of this bug: 896906
As said in bug 896906, the same appears in 
/mozilla/mobile/android/base/tests/robocop_head.js
    line 116 -- if (iid.Equals(Components.interfaces.nsITimerCallback) ||
    line 117 -- iid.Equals(Components.interfaces.nsISupports))
Attached patch The fix v2Splinter Review
Including the android fix, switching reviewer as Ted's away.
Attachment #779458 - Attachment is obsolete: true
Attachment #779458 - Flags: review?(ted)
Attachment #779682 - Flags: review?
Attachment #779682 - Flags: review? → review?(jmaher)
Comment on attachment 779682 [details] [diff] [review]
The fix v2

Review of attachment 779682 [details] [diff] [review]:
-----------------------------------------------------------------

looks good to me.
Attachment #779682 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f2626641f86
Assignee: nobody → mbanner
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla25
https://hg.mozilla.org/mozilla-central/rev/3f2626641f86
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Blocks: 889911
Comment on attachment 779682 [details] [diff] [review]
The fix v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 889911
User impact if declined: None
Testing completed (on m-c, etc.): landed on inbound
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none

This regressed because bug 889911 was block-approved as part of another bug to land on aurora. Unfortunately, that causes Thunderbird many strict errors and warnings, which we are now tidying up. This patch tides up javascript strict errors in mozilla-central.
Attachment #779682 - Flags: approval-mozilla-aurora?
Attachment #779682 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.