Test output looks very strange, and is useless for failing tests

RESOLVED FIXED in mozilla26

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: erikvold, Assigned: dcamp)

Tracking

unspecified
mozilla26
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I'm getting stuff like this:

`console.info: pathfinder: pass:, css is unregistered.`

The `console.info:` stuff is not useful.

The `pass:,` is just strange..  why is there a `,` char?
I've been seeing odd tracebacks too. Is this related to switching away from using a file for output Irakli?
Flags: needinfo?(rFobic)
No it's related to switching to devtools console I believe, probably because they print stack traces differently then we did.
Flags: needinfo?(rFobic)
This stuff is really killing my productivity..

console.info: pathfinder: executing 'pathfinder/tests/test-storage.testSetThenGet'
console.error: pathfinder: 
  fail:
  An error occured
console.trace: pathfinder: 
_ecated/unit-test.js 89 _
_/sdk/test/assert.js 74 _
_sts/test-storage.js 21 _
_sdk/core/promise.js 137 _
_sdk/core/promise.js 56 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 212 _
_nder/lib/storage.js 81 _
_modules/NetUtil.jsm 85                                                                            
                     0                                                                            

console.log: pathfinder: 2222
console.error: pathfinder: 
  fail:
  the data returned from get is correct 0.04738361818771386 - "0.04738361818771386" == ""
console.trace: pathfinder: 
_ecated/unit-test.js 89 _
_/sdk/test/assert.js 89 _
_/sdk/test/assert.js 125 _
_sts/test-storage.js 23 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 47 _
_sdk/core/promise.js 157 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 47 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 137 _
_sdk/core/promise.js 56 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 212 _
_nder/lib/storage.js 81 _
_modules/NetUtil.jsm 85                                                                            
                     0                                                                            

console.error: pathfinder: 
  fail:
  An error occured
console.trace: pathfinder: 
_ecated/unit-test.js 89 _
_/sdk/test/assert.js 74 _
_sts/test-storage.js 27 _
_sdk/core/promise.js 137 _
_sdk/core/promise.js 56 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 131 _
_sdk/core/promise.js 47 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 47 _
_sdk/core/promise.js 157 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 122 _
_sdk/core/promise.js 47 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 137 _
_sdk/core/promise.js 56 _
_sdk/core/promise.js 189 _
_sdk/core/promise.js 212 _
_nder/lib/storage.js 81 _
_modules/NetUtil.jsm 85                                                                            
                     0
Do you want to look into what is causing it then?

Updated

5 years ago
Assignee: nobody → evold
Priority: -- → P1
Summary: Test output looks very strange → Test output looks very strange, and is useless for failing tests
How did this get assigned to me?  I'm busy enough, let's just revert the commit Irakli is referring to, I don't know who landed it or where.

Irakli do you know?
Assignee: evold → nobody
Flags: needinfo?(rFobic)
He's talking about bug 850296 I think and while we could back that out for a time we still need someone to figure out what the problem is and how to fix it. I assigned it to you because you were the one complaining about it. Everyone is busy.
I'm not actually seeing this problem anyway, are you testing on a recent Nightly of Firefox?
Assignee: nobody → dcamp
(Assignee)

Comment 8

4 years ago
Created attachment 786513 [details] [diff] [review]
console-trace-fix-I-guess-I-should-test-things.diff

Proving that positional optional arguments are sad, max length comes before min length for this particular call.
Attachment #786513 - Flags: review?(jwalker)
> (In reply to Erik Vold [:erikvold] [:ztatic] from comment #5)
> How did this get assigned to me?  I'm busy enough, let's just revert the
> commit Irakli is referring to, I don't know who landed it or where.
> 
> Irakli do you know?


It was Jordan, but looks like Dave is on it, so I'm not sure it's worth reverting it now.
Flags: needinfo?(rFobic)
Attachment #786513 - Flags: review?(jwalker) → review+
(Assignee)

Comment 10

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/f8879459be35
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f8879459be35
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla26

Comment 12

4 years ago
(In reply to Erik Vold [:erikvold] [:ztatic] from comment #12)
> I'm getting stuff like this:
> 
> `console.info: pathfinder: pass:, css is unregistered.`
> 
> The `console.info:` stuff is not useful.
> 
> The `pass:,` is just strange..  why is there a `,` char?

The comma should be fixed per bug 880752 (which I just relanded, including some modifications in the expectations of jetpack tests).
You need to log in before you can comment on or make changes to this bug.