[MMS] Showing wrong error message when opening the SMS application after the home button is pressed

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::SMS
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: Leo)

Tracking

unspecified
1.1 QE5
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [TD-67660], [LeoVB+])

Attachments

(1 attachment)

358 bytes, text/html
borjasalguero
: review+
Details
(Assignee)

Description

5 years ago
1. Title: Showing wrong error message when opening the SMS application after the home button is pressed
2. Precondition: SMS app should be working
3. Tester's Action:  (1) Receive MMS with image or audio or video file
                     (2) Click on any received image or music file or video file
                     (3) Press "Home" button
                     (4) Open SMS application 
4. Detailed Symptom (ENG.) : 'There is no application available to open this file' error window is shown
5. Expected:  When message application is open after clicking on the Home button,this error window should not be shown
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train
8. Gaia Revision:  bbad03e30527e1df8261a462e5cefbdc562f0819
9. Personal email id: sasikala.paruchuri8@gmail.com
(Assignee)

Updated

5 years ago
Whiteboard: [TD-67660]
(Assignee)

Comment 1

5 years ago
Created attachment 780192 [details]
pointer to pull request

Please review the patch and provide your comments
Attachment #780192 - Flags: review?(fbsc)
Small comment in your PR, please address the change and I'll test this again! Thanks
Assignee: nobody → leo.bugzilla.gaia
(Assignee)

Comment 3

5 years ago
Hi Borja,
I have added the comments in PR.Can you please check that and update.
Thanks
Hi Leo, please re-check the PR :)
(Assignee)

Comment 5

5 years ago
(In reply to Borja Salguero [:borjasalguero] from comment #4)
> Hi Leo, please re-check the PR :)

Hi Borja,

Tested and updated the PR as per the comments.
Please check.

Thanks,
Comment on attachment 780192 [details]
pointer to pull request

Probably we could add this to leo+, due to is a surgical fix. Wdyt?
Attachment #780192 - Flags: review?(fbsc) → review+

Comment 7

5 years ago
I set leo+ because this is vendor's QE issue and hope to landed in V1-train for sync-up with vendor build.
blocking-b2g: --- → leo+
Target Milestone: --- → 1.1 QE5
(Assignee)

Updated

5 years ago
Whiteboard: [TD-67660] → [TD-67660], [LeoVB+]
Leo, Why is this not landed yet? Can I help you with this? It's r+ and leo+. Let me know!
Flags: needinfo?(leo.bugzilla.gaia)
(Assignee)

Comment 9

5 years ago
Hi Borja,
We dont have permissions for uplifting.
So,Please land this issue on behalf of Leo.
Thanks,
Flags: needinfo?(leo.bugzilla.gaia)
https://github.com/mozilla-b2g/gaia/commit/fc22e7385dccf60ada2e48f17c465d8662317e44
https://github.com/leob2g/gaia/commit/b57cc2c66964c5d1829e90a7a9d75274dcfe1051

John, could you take a look to this uplift? Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jhford)
Resolution: --- → FIXED
Uplifted fc22e7385dccf60ada2e48f17c465d8662317e44 to:
v1-train: caa91ce227fe3749fe669761db89706a1f2de959
status-b2g18: --- → fixed
Flags: needinfo?(jhford)
v1.1.0hd: caa91ce227fe3749fe669761db89706a1f2de959
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.