Closed Bug 897077 Opened 7 years ago Closed 7 years ago

Firefox switches to non-private window sometimes when on private browsing

Categories

(Firefox :: Private Browsing, defect)

23 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 768802

People

(Reporter: d.marketing, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130715155216

Steps to reproduce:

Start Firefox.
Click [LCtrl]+[LShift]+[P] to open private browsing window (I still have the non-private window open)
At the search bar search something
Click on the first result that showed on search results


Actual results:

Immediately as the page loaded, Firefox switched to the non-private window.
It didn't close the private window, but it switched immediately to the non-private window, as if I had minimized the private window.


Expected results:

What should have happened is pretty obvious IMHO, the private window should not "minimize" (it should stay where it is, and not switch focus to the non-private window)
It should also be noted that it happens only sometimes, not always.
Component: Untriaged → Private Browsing
This sounds like bug 833048, which is a dup of bug 768802.
toni, if you disable the Flash Player plugin in Firefox, are you able to repro the issue?

In addition, you can test with protected mode disabled in Flash, see http://forums.adobe.com/thread/1018071?tstart=0 (§ "last resort")
Flags: needinfo?(d.marketing)
Nope, it never happened with Shockwave Flash disabled.
Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(d.marketing)
Resolution: --- → DUPLICATE
Duplicate of bug: 768802
You need to log in before you can comment on or make changes to this bug.