Closed Bug 897180 Opened 9 years ago Closed 9 years ago

Selecting a link from settings doesn't launch the web page correctly in browser if the browser app is already open

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 896945
blocking-b2g leo+

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

1. launch browser
2. hit home
3. launch settings 
4. go to Improve Firefox OS 
5. scroll to "Crash reports" section and select Learn More
6. select "privacy policy"

Expected: Switches to Browser app and launches privacy page
Actual: Switches to the browser app and doesn't load

Note:
Additional Nits:
1. there should be a space between "our" and "privacy policy"
2. is there a reason for the https page versus http page?
Attached file logcat.txt
Attached is the logcat

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia   ffe25bfdf0e71c820ca710cb61fb8306564a8f4e
BuildID 20130723070209
Version 18.0
Occurs on master w/ unagi as well : 
gecko : 27cd5f2dd44b576a8faabaab239fd3250ff8fef9
gaia : 4f8ffa9b3915a788477aa97197181feb26590fe8
build id : 2013-07-23-03-02-02
blocking-b2g: --- → leo?
I found this bug is very similar with bug 896945. 
mozSetMessageHandler does not trigger the callback with data (link of privacy policy).
Keywords: regression
blocking-b2g: leo? → leo+
This will be fixed when 896945 lands given : https://bugzilla.mozilla.org/show_bug.cgi?id=896945#c12
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896945
You need to log in before you can comment on or make changes to this bug.