Need finalized artwork for Bookmarks Menu button

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Theme
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mak, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {icon})

Trunk
Firefox 29
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P2])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
I am using placeholders for the dropdown button graphic in bug 855805, we need proper icons.
(Reporter)

Updated

5 years ago
Flags: needinfo?(shorlander)
Keywords: icon
Whiteboard: [Australis:M?][Australis:P1]
(Reporter)

Updated

5 years ago
Blocks: 872617
Created attachment 795658 [details]
Screenshot of current icons

Is this a valid bug anymore? The bookmark star and menu icon doesn't look crappy to me.
Flags: needinfo?(mak77)
At its current state, this isn't a P1. Dropping this down to a P4 since it doesn't seem like many users will complain right away about it, and it shouldn't stop us from merging in to m-c.
Whiteboard: [Australis:M?][Australis:P1] → [Australis:M?][Australis:P4]

Comment 3

5 years ago
I think it looks pretty bad.  The screenshot you attached looks a bit better than what is currently on osx though.
(In reply to Jordan from comment #3)
> I think it looks pretty bad.  The screenshot you attached looks a bit better
> than what is currently on osx though.

OK, thanks. I just checked and I agree it looks worse on OSX.
OS: All → Mac OS X
Version: unspecified → Trunk
(Reporter)

Comment 5

5 years ago
(In reply to Jared Wein [:jaws] from comment #4)
> OK, thanks. I just checked and I agree it looks worse on OSX.

regardless, the images have been quickly edited as placeholders, not intended to be released at all, we need the hands of a graphic designer here.
Flags: needinfo?(mak77)
Flags: needinfo?(shorlander)
Summary: Replace crappy images from bug 855805 → Need finalized artwork for Bookmarks Menu button
Icanhasicons? :-)
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M?][Australis:P2]

Comment 8

5 years ago
IMHO, this now ends up as being something that we probably should track on bug 939862. The current icon is very easy to confuse with the "Hamburger" menu button, which in the default set is even pretty near to it.
I already find it somewhat of a mental effort to get used to the "Hamburger" button, having something almost next to it that looks almost the same is definitely distracting and making it harder to learn the new UI.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #8)
> IMHO, this now ends up as being something that we probably should track on
> bug 939862. The current icon is very easy to confuse with the "Hamburger"
> menu button, which in the default set is even pretty near to it.
> I already find it somewhat of a mental effort to get used to the "Hamburger"
> button, having something almost next to it that looks almost the same is
> definitely distracting and making it harder to learn the new UI.

This doesn't make any sense. Bug australis-merge is specifically about issues which were discovered once we merged. We've always known this was an issue, ever since implementing this, but no new artwork has been provided so it's still the same. Making it block that bug won't increase the priority, which is already very high.

Comment 10

5 years ago
OK, I just wanted to make sure we address this because I think it will make the transition easier (or at least it would for me).
Would you like the glyph delivered solo or added to all toolbar.png sprites?
Flags: needinfo?
(In reply to mmaslaney from comment #11)
> Would you like the glyph delivered solo or added to all toolbar.png sprites?

I believe we can replace the existing placeholder icon in Toolbar.png
Flags: needinfo?
Created attachment 8346223 [details]
fx_Toolbar.zip

Is Linux using the OS X toolbar?
Flags: needinfo?(MattN+bmo)
(In reply to mmaslaney from comment #13)
> Created attachment 8346223 [details]
> fx_Toolbar.zip
> 
> Is Linux using the OS X toolbar?

Linux and Windows seem to be the same. OS X is different. See images below:
* Linux:   https://mxr.mozilla.org/mozilla-central/source/browser/themes/linux/Toolbar.png
* Windows: https://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/Toolbar.png
* OS X:    https://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/Toolbar.png
Flags: needinfo?(MattN+bmo)
OK, great. Wanted to make sure we're covered for Linux assets. Thank you.

Comment 16

5 years ago
(In reply to mmaslaney from comment #15)
> OK, great. Wanted to make sure we're covered for Linux assets. Thank you.

I think win aero is different from win XP assets, just to clarify, the assets that are the same as Linux are the XP while the one in the zip file is win7
(In reply to Tim Nguyen [:ntim] from comment #16)
> (In reply to mmaslaney from comment #15)
> > OK, great. Wanted to make sure we're covered for Linux assets. Thank you.
> 
> I think win aero is different from win XP assets, just to clarify, the
> assets that are the same as Linux are the XP while the one in the zip file
> is win7

AFAICT there are folders for all of winXP/win7/win8 in the zip file, with corresponding images.
(In reply to Matthew N. [:MattN] from comment #14)
> (In reply to mmaslaney from comment #13)
> > Created attachment 8346223 [details]
> > fx_Toolbar.zip
> > 
> > Is Linux using the OS X toolbar?
> 
> Linux and Windows seem to be the same.

That's a bug. Linux shouldn't use the XP-style colored icons. The current Toolbar.png is basically a placeholder.

Comment 19

5 years ago
(In reply to :Gijs Kruitbosch (Extremely limited availability until Dec. 18, then PTO until January 2) from comment #17)
> (In reply to Tim Nguyen [:ntim] from comment #16)
> > (In reply to mmaslaney from comment #15)
> > > OK, great. Wanted to make sure we're covered for Linux assets. Thank you.
> > 
> > I think win aero is different from win XP assets, just to clarify, the
> > assets that are the same as Linux are the XP while the one in the zip file
> > is win7
> 
> AFAICT there are folders for all of winXP/win7/win8 in the zip file, with
> corresponding images.

Oh sorry, I haven't noticed the XP assets.

(In reply to Dão Gottwald [:dao] from comment #18)
> (In reply to Matthew N. [:MattN] from comment #14)
> > (In reply to mmaslaney from comment #13)
> > > Created attachment 8346223 [details]
> > > fx_Toolbar.zip
> > > 
> > > Is Linux using the OS X toolbar?
> > 
> > Linux and Windows seem to be the same.
> 
> That's a bug. Linux shouldn't use the XP-style colored icons. The current
> Toolbar.png is basically a placeholder.

You're probably right. Stephen's new mockups introduce black icons.
Assignee: shorlander → mmaslaney
Duplicate of this bug: 950937
(In reply to Dão Gottwald [:dao] from comment #18)
> That's a bug. Linux shouldn't use the XP-style colored icons. The current
> Toolbar.png is basically a placeholder.

Will that bug be fixed here or in a new bug? If that's happening in a new bug, is there anything else blocking the work here? (except the holidays of course!) ;-)
(In reply to Peter Retzer (:pretzer) from comment #21)
> (In reply to Dão Gottwald [:dao] from comment #18)
> > That's a bug. Linux shouldn't use the XP-style colored icons. The current
> > Toolbar.png is basically a placeholder.
> 
> Will that bug be fixed here or in a new bug? If that's happening in a new
> bug, is there anything else blocking the work here? (except the holidays of
> course!) ;-)

A new bug, and no, we just need to stick the new assets in the tree. I'll see if I have time to pick this up today.
Flags: needinfo?(gijskruitbosch+bugs)
Created attachment 8355238 [details] [diff] [review]
need finalized artwork for Australis Bookmarks Menu,

So this does the right thing for this particular button on OS X. Fixing the star button to not get highlighted is more involved so I didn't want to do it in this bug, because it already happens, and I couldn't even remember for sure if it was by design or not.
Attachment #8355238 - Flags: review?(mdeboer)
Assignee: mmaslaney → gijskruitbosch+bugs
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8355238 [details] [diff] [review]
need finalized artwork for Australis Bookmarks Menu,

Review of attachment 8355238 [details] [diff] [review]:
-----------------------------------------------------------------

First, apologies for the late review!

Since Linux uses the Windows icons, can you add that to this patch?

A question that does not relate to this bug directly: I noticed that icons for Windows 8 are specifically included in the zip file... shall I take it to bug 859751?
Attachment #8355238 - Flags: review?(mdeboer) → review-
Comment on attachment 8355238 [details] [diff] [review]
need finalized artwork for Australis Bookmarks Menu,

Review of attachment 8355238 [details] [diff] [review]:
-----------------------------------------------------------------

I don't know if the images were compressed the same way as the images that are currently in the repo, but the image sizes differ quite a bit for an addition of 'just' one icon. Especially the file sizes on OSX differ quite substantially.

I will take the Win8 glyphs and add them in bug 859751.
Attachment #8355238 - Flags: review- → review+
(In reply to Mike de Boer [:mikedeboer] from comment #25)
> Comment on attachment 8355238 [details] [diff] [review]
> need finalized artwork for Australis Bookmarks Menu,
> 
> Review of attachment 8355238 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I don't know if the images were compressed the same way as the images that
> are currently in the repo, but the image sizes differ quite a bit for an
> addition of 'just' one icon. Especially the file sizes on OSX differ quite
> substantially.

Well-spotted! Stephen told me he normally puts his through ImageOptim, so I did the same before committing this (and saved an average of 17.6%, apparently):

remote:   https://hg.mozilla.org/integration/fx-team/rev/ac385aa66e48
Whiteboard: [Australis:M?][Australis:P2] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ac385aa66e48
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 29

Updated

4 years ago
Depends on: 958413
You need to log in before you can comment on or make changes to this bug.