If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla treats width="" as width="0"

RESOLVED DUPLICATE of bug 75250

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 75250
16 years ago
4 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: karnaze (gone))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build: 2001070604, Mac OS 9.1

To reproduce:
*   Open the attached testcase.

What you should see:
|
| We hold these truths to be self-evident, that all men are created equal,
| that they are endowed by their Creator with certain unalienable Rights, and
| that Mozilla should not assume that width="" means width="0".

What you actually see:
|
| We hold
| these truths
| to be
| self-evident,
| that all men
| are created
| equal, that
| they are
| endowed by
|...
etc. This is very tiring to read.

I see nothing in the HTML specification which says that width="" should be 
treated as width="0". None of 
<http://www.w3.org/TR/html4/struct/tables.html#adef-width-TABLE>,
<http://www.w3.org/TR/html4/types.html#type-length>, or
<http://www.w3.org/TR/html4/sgml/dtd.html#Length> say what should happen with a 
width="", and the safest thing to do would seem to be ignoring it entirely.
(Reporter)

Comment 1

16 years ago
Created attachment 41531 [details]
How Doc Searls' page looks in Mozilla currently
(Reporter)

Comment 2

16 years ago
Created attachment 41532 [details]
testcase

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 75250 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.