Closed Bug 897398 Opened 9 years ago Closed 9 years ago

Tapping email address in contacts or sms should display email 'compose' screen, but if email app is already open it just displays whatever screen the app has open.

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 896945

People

(Reporter: roy.collings, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

Using build: unagi-ICS.eng.v1-train.Rel0.4.Sprint12.B-167.Gecko-f94f793.Gaia-ef03c2b

1. Open emai lapp and set up an account (so you can send and receive emails).
2. Without closing the email app, open the contacts app.
3. View a contact with an email address and tap the email address.

(NOTE: This also happens when clicking an email address in an sms message.)


Actual results:

The email app appears, displaying the Inbox (the last screen you used in the email app).


Expected results:

The email app should appear with the 'compose new message' screen displayed.

(NOTE: If the email app is closed when you click the email address, then it launches and displays the correct 'compose' screen as expected.)
blocking-b2g: --- → leo?
Keywords: regression
It might come from the same cause of bug 896945 , mozSetMessageHandler does not trigger the handler.
Antonio - Is this a dupe of bug 896945?
Flags: needinfo?(amac)
Yep it is.
Flags: needinfo?(amac)
Status: UNCONFIRMED → RESOLVED
blocking-b2g: leo? → ---
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896945
You need to log in before you can comment on or make changes to this bug.