Should persist size/position of last open window, not last-opened window

VERIFIED FIXED in mozilla0.9.5

Status

--
minor
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: mpt, Assigned: danm.moz)

Tracking

Trunk
mozilla0.9.5
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2001070604, Mac OS 9.1

To reproduce:
1.  Ensure that your startup prefs are set to open only a Navigator window.
2.  Quit and restart Mozilla.
3.  Resize your Navigator window to something approaching full-screen size.
4.  Use Command+click to open a link on your home page in a new window.
5.  Shrink the new window so that you can easily flick between the two windows.
6.  Close the new window.
7.  Quit Mozilla.
8.  Restart Mozilla.

What happens:
*   A new Navigator window is created with the size and position of the most
    recently opened manually-opened Navigator window (the small one).

What should happen:
*   A new Navigator window is created with the size and position of the most
    recently open manually-opened Navigator window (the large one).

Note that `manually opened' means this doesn't apply to windows opened by a
script, even if the user clicked on a link to invoke that script.
->danm?
Assignee: pchen → danm
QA Contact: sairuh → claudius
(Assignee)

Comment 2

18 years ago
Confounded performance optimizations. The problem is Mozilla isn't saving the 
state of the first window when it's activated as the second window is closed. 
It's supposed to. The patch in bug 86955 also fixes this bug.
Status: NEW → ASSIGNED
Depends on: 86955
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

18 years ago
Target Milestone: mozilla1.0 → mozilla0.9.5
(Assignee)

Comment 3

18 years ago
Fixed. See patch in bug 86955.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

17 years ago
Verified fixed, build 2001110908, Mac OS 9.1. Thankyou so much.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.