Firefox won't update a saved password if autocomplete=off and continues to autocomplete the old one

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: taras.mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
I have also had this issue, on Windows 7. Everything was working fine before the Zimbra upgrade and it hasn't work since.
OS: Windows 8 → All
We're honouring Zimbra's newly added autocomplete=off on the password field here by not auto-filling and not asking to save the password. We do still autocomplete the username/password combo in this case.

Perhaps we should still allow a user to update a password if they managed to save one for the same username in the past?
Hardware: x86_64 → All
(Reporter)

Comment 3

5 years ago
(In reply to Matthew N. [:MattN] from comment #2)
> We're honouring Zimbra's newly added autocomplete=off on the password field
> here by not auto-filling and not asking to save the password. We do still
> autocomplete the username/password combo in this case.
> 
> Perhaps we should still allow a user to update a password if they managed to
> save one for the same username in the past?

This sounds like the cause and yes please. Also we need to file an IT ticket to remove this zimbra idiocy.
(In reply to Taras Glek (:taras) from comment #3)
> Also we need to file an IT ticket to remove this zimbra idiocy.

I filed bug 897731 for our Zimbra setup.
Summary: When logging in with a new password into zimbra I'm not prompted to update my stored password :( → Firefox won't update a saved password if autocomplete=off and continues to autocomplete the old one
No longer blocks: 951981
I confirmed this is fixed by bug 956906 in Nightly.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.