Only upper-left quadrant of plugin drawn on Nightly

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

({helpwanted, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 780768 [details]
Screenshot of problem

Some pages with plugins are only drawing the upper-left part of the plugin.

Screenshot attached for http://www.jwz.org/blog/2013/07/numbers-stations-always-awesome/ (embedded YouTube) The video plays properly on youtube.com.

Sometimes the rest of the video will be draw, scrolling the page makes it randomly appear/disappear. (Upon trying again, it's now doing that only when scrolling, but that wasn't what I remember seeing earlier.)

I also see this on videos at liveleak.com. https://people.mozilla.com/~dolske/donuts.swf is fine, though.


This seems to be a recent regression (last few days) on Nightly. I'm on a Retina (hidpi) MBP.
I've noticed that today as well. Adobe seems to have released an update for Flash Player yesterday. You may have been updated silently. I've confirmed that I have version 11.8.800.120 now. Looking at the release notes[1], this 'fixed' bug seems related to what we're seeing:
>StageWebView.drawViewPortToBitmapData draws incorrect bitmap on retina
>devices(3558603)

[1] http://helpx.adobe.com/en/flash-player/release-note/fp_118_air_38_release_notes.html
11.8.800.94 seems to be the most recent released Flash Player for OS X.
It works fine for me on my non-retina Mac.

Hm, the Apple dev center is still down - can a Retina user please check if that was regressed in Flash or Firefox?
Keywords: helpwanted, regression
Does QA have Mac Retina devices to check on?
Keywords: qawanted
I can't reproduce this bug at http://www.jwz.org/blog/2013/07/numbers-stations-always-awesome/, testing with today's mozilla-central nightly on a Retina MacBook Pro running OS X 10.7.5.

Any other examples?  Any special steps?

I tested with the latest Flash release (installed today), which is 11.8.800.94.
(In reply to Georg Fritzsche [:gfritzsche] from comment #3)
> Does QA have Mac Retina devices to check on?
I don't have. Anthony ?
Matt, can you please see if you can reproduce this issue?
QA Contact: mwobensmith
I can reproduce this on a Mac Retina, but it does not appear to be a problem in the latest m-c nightly.

I tried three builds:
2013-06-26 good
2013-07-17 bad
2013-08-01 good

If someone really needs a regression range, I can help, but it would likely be after the release next week.
If this has ceased to become an issue on Nightly then I suggest we just resolve this WORKSFORME. Dolske, spohl, is this still an issue for you in the latest Nightly?
Keywords: qawanted
When this first started happening, I've found that it is fairly intermittent. I couldn't reproduce with the latest nightly however.
Flags: needinfo?(dolske)
Thanks Georg, I think we should call this WORKSFORME until such time that we have more concrete evidence of a bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

4 years ago
(Current breakage seems to be covered by bug 907792)
Flags: needinfo?(dolske)
You need to log in before you can comment on or make changes to this bug.