Closed Bug 897901 Opened 7 years ago Closed 7 years ago

Bug 894099 broke native titlebar features on XP when maximized

Categories

(Core :: Widget: Win32, defect)

All
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: MattN, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [Australis:P1])

Double-clicking in the titlebar to maximize/restore and right-clicking to get the system window context menu (with minimize, maximize, close, etc.) no longer work. :(

With Australis this affects restored windows too.
NB: note that on non-Australis, this only affects profiles which have the menubar turned off.
Felipe, any ideas to make this work?
Flags: needinfo?(felipc)
Yeah, it should still be possible to make it work. The maximize/restore should be simple, we can just have a dblclick listener in WindowDraggingUtils.jsm that calls window.maximize()/window.restore() depending on the "sizemode" attr on the window.

The context menu I thought it should already be working, but apparently not. Still, we could do the hittest only for a WM_RBUTTONDOWN and if we detect it's over a blank area, we call DisplaySystemMenu.  This will be a little more complicated because then WindowDraggingUtils.jsm will still have to listen to MozMouseHittest to answer this case, while also handling the window drag through the mousedown path.
But definitely doable if we need to take the patch again.
Flags: needinfo?(felipc)
Breaking standard OS windows control is bad, P1. :(
Whiteboard: [Australis:P1]
Fixed via backout of bug 894099: https://hg.mozilla.org/projects/ux/rev/eb94d597ec47
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.