Closed Bug 898067 Opened 6 years ago Closed 6 years ago

[B2G][Gallery] Sluggish metadata scanning performance.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-)

RESOLVED WORKSFORME
blocking-b2g -

People

(Reporter: ndavidson, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [c=progress p= s=2014.02.14 u=])

Attachments

(3 files)

Description:
When launching gallery on freshly flashed device user getting pop-up message "No photos or videos" - "Use the Camera app to get started" for about 3-4 seconds before pic scan process starts and user starting to see pic. thumbnails to flow in. 

Repro Steps:
1) Updated Leo to Build ID: 20130725070209
2) Tap on a Gallery icon from home screen
3) Observe what happen

Actual:
User getting pop-up message "No photos or videos" - "Use the Camera app to get started" for about 3-4 seconds before pic scan process starts 

Expected:
User should see picture thumbnails rightghtaway without error message

Environmental Variables
Build ID: 20130725070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia: b1945e7eca58c9176d91998390871864f5e8eb3e
Platform Version: 18.1

Notes:
Repro frequency:  100%, (only on freshly flashed or device that been reset)
Q Analysts Team Priority:  Pri 3
See attached: screenshot, logcat,
Issue in comment 0 found on Leo v1.1 Commercial
blocking-b2g: --- → leo?
Issue also found on Unagi v1.1.0 Mozilla RIL
Build ID: 20130725070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia: b1945e7eca58c9176d91998390871864f5e8eb3e
Platform Version: 18.1

and 

Unagi v1.2.0 Mozilla RIL
Build ID: 20130725030211
Gecko: http://hg.mozilla.org/mozilla-central/rev/a4c1961bf723
Gaia: c7272f0b45c9fdac9d551828987e343300e87bf6
Platform Version: 25.0a1

Recommend escalation to Pri 2
Keywords: perf, regression
Pri 2 suggests this wouldn't be considered a blocker.
blocking-b2g: leo? → -
It's annoying having said that there's a candystrip bar that shows transparently at the top and indicates stuff is happening and loading.

Tested on 1.2 unagi and 1.1 leo.

Video shows 1.2 unagi: http://www.youtube.com/watch?v=iv4Rxz1ugZs
Using Leo device and:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia   b1945e7eca58c9176d91998390871864f5e8eb3e
BuildID 20130725070209
Version 18.1

I don't see an issue with a small amount of pictures. 

With 61 pictures the scan time was approximately 2.56 seconds from the time I pushed the gallery button until the time the pictures started rendering.
No longer blocks: b2g-central-dogfood
Whiteboard: [c= p=]
Issue still repro for about 3 seconds on leo device User getting pop-up message "No photos or videos" - "Use the Camera app to get started" 
LEO Build ID: 20130812041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/36bbc5943448
Gaia: c60e3507d9df160e006d2e25967d26df2dc543cb
Platform Version: 18.1
RIL Version: 01.01.00.019.184 

on Unagi v 1.2 user will get different screen which is saying: "Scanning" "looking for photos and videos" for 2-3 sec which can be seen as screenshot  attachment, and  YouTube video from comment 5
Environmental  Variables:
Build ID: 20130811040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d20597e0a07
Gaia: 1b9019acdc1eea9cfe78edeb914eba6e8153fbbe
Platform Version: 26.0a1
See Also: → 796473
Whiteboard: [c= p=] → [c=progress p= s= u=]
Is this still an issue? If it isn't an issue, we'll close it. From datazilla, it looks like cold launch time stayed the same. Also, are we still supporting ungai devices as stated from comment #7. Thanks!
Keywords: qawanted
Priority: -- → P3
QA Contact: sarsenyev
When loading "Gallery" it says "scanning..."
When loading video and audio it says "load... to memory card"
Loading time is pretty quick, there is no requirement for the cold load time, but it took me less than 3 sec to load the first image with full memory card

Device: Buri 1.3 MOZ
BuildID: 20140213004002
Gaia: 999808c18d2fc95f14d65b925f25237e78436f56
Gecko: 6279534238d8
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Closing this as I don't think there's much to do here at this point.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [c=progress p= s= u=] → [c=progress p= s=2014.02.14 u=]
You need to log in before you can comment on or make changes to this bug.