Closed Bug 898202 Opened 6 years ago Closed 6 years ago

[B2G][MMS]Unable to send/receive MMS using AT&T or prepaid T-Mobile SIMs

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
blocking-b2g leo+
Tracking Status
firefox23 --- wontfix
firefox24 --- wontfix
firefox25 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: nkot, Assigned: ctai)

References

Details

(Whiteboard: [LeoVB+])

Attachments

(3 files, 2 obsolete files)

Attached file logcat
Description:
 B2G devices are having issues to send/receive MMS using AT@T or prepaid T-Mobile SIMs. 
 Naoki suggested to file a bug as this is a blocking issue. 

Repro Steps:
1) Updated Buri/Inari/Leo/Unagi to Build ID: 20130725070209
2) Send MMS from a Test device
3) Receive MMS to a Test device

Actual:
 - for sent MMS: message is shown as sending(spinning), but never gets delivered
 - for received MMS: the user recieves SMS notification "I have sent you a file. It will be available until ..." 

Expected:
 - the user is able to send/receive MMS successfully

Environmental Variables
Build ID: 20130725070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia: b1945e7eca58c9176d91998390871864f5e8eb3e
Platform Version: 18.1
Attached patch bug-898202.patch (obsolete) — Splinter Review
Attached patch Patch v1.1 (obsolete) — Splinter Review
Attachment #781539 - Attachment is obsolete: true
Component: Gaia → DOM: Device Interfaces
Product: Boot2Gecko → Core
Attachment #781540 - Flags: review?(vyang)
According to the log, the root cause is this SIM card has no mms port value in apn.json. So give an default mms port=80 might a solution.
Attachment #781540 - Attachment is obsolete: true
Attachment #781540 - Flags: review?(vyang)
Attachment #781621 - Flags: review?(vyang)
Assignee: nobody → ctai
Attachment #781621 - Flags: review?(vyang) → review+
individual carrier json file is stored here, I think?  https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/apn.json

I went to Settings -> Cellular & Data -> Message settings -> Advanced settings and placed 80 in the MMS port and hit ok; went back to Message settings and verified that it changed to custom settings and kept the change

I sent a MMS message after that and it sent correctly.

Thanks, Chia, for fixing this really quickly!  We have a manual way to change this as well.
blocking-b2g: --- → leo?
Hi Vicamo,
Do you think it's necessary that we also set default port to 80 in gaia settings?
Flags: needinfo?(vyang)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> I went to Settings -> Cellular & Data -> Message settings -> Advanced
> settings and placed 80 in the MMS port and hit ok; went back to Message
> settings and verified that it changed to custom settings and kept the change
> 
> I sent a MMS message after that and it sent correctly.

works for me too!
was able to send and receive MMS successfully

Leo, 
Build ID: 20130726070208
Yes, individual carrier apn is in https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/apn.json.
Cingular 410 is missing mms port in that file.


(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> individual carrier json file is stored here, I think? 
> https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/apn.json
> 
> I went to Settings -> Cellular & Data -> Message settings -> Advanced
> settings and placed 80 in the MMS port and hit ok; went back to Message
> settings and verified that it changed to custom settings and kept the change
> 
> I sent a MMS message after that and it sent correctly.
> 
> Thanks, Chia, for fixing this really quickly!  We have a manual way to
> change this as well.
Attachment #782366 - Attachment filename: bug-898202-b2g18.ppatch → bug-898202-b2g18.patch
Attachment #782366 - Attachment description: bug-898202-b2g18.ppatch → bug-898202-b2g18.patch
Attachment #782366 - Attachment is obsolete: true
(In reply to Steve Chung [:steveck] from comment #6)
> Hi Vicamo,
> Do you think it's necessary that we also set default port to 80 in gaia
> settings?

We have default port 80 in Gecko for better error handling.  If Gaia needs that numeric value set to a correct one as well, then you might want to do the same.
Flags: needinfo?(vyang)
Triage - partner agrees to take this in.
blocking-b2g: leo? → leo+
https://hg.mozilla.org/mozilla-central/rev/e1ba01c5cc0d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Attachment #782366 - Attachment is obsolete: false
Whiteboard: [LeoVB+]
You need to log in before you can comment on or make changes to this bug.