Closed Bug 898322 Opened 9 years ago Closed 9 years ago

If dialer is open when tapping a number in an SMS, the dialer appears but the number doesn't change.

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 896945

People

(Reporter: roy.collings, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

Using build: unagi-ICS.eng.v1-train.Rel0.4.Sprint12.B-169.Gecko-d1529e4.Gaia-055c122

1. Receive and SMS containing 2 numbers: "123456798 and 987654321".
2. Tap the 1st number (dialer opens with this number in it).
3. Switch back to the sms app (without killing the dialer).
4. Tap the 2nd number.


Actual results:

The dialer appears again but it still contains the 1st number.


Expected results:

The dialer should appear, but with the 2nd number.

(This seems to be similar to bug 896945, which relates to tapping an sms number from contacts.)
blocking-b2g: --- → leo?
Keywords: regression
It seems the same problem of bug 896945 . setMessageHandler in dialer app does not get the message from sms app if dialer is already opened.
Status: UNCONFIRMED → RESOLVED
blocking-b2g: leo? → ---
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896945
Tested on Unagi device. 
Build:unagi-ICS.user.manifest.V1-train.Rel0.4.Sprint12.B-332.Gecko-f89d83b.Gaia-6221737
Build ID:20130730104759
Commercial RIL: AU 172

STEPS:
1. Receive and SMS containing 2 numbers: "123456798 and 987654321".
2. Tap the 1st number (dialer opens with this number in it).
3. Switch back to the sms app (without killing the dialer).
4. Tap the 2nd number.

Expected result:
The dialer should appear, but with the 2nd number

Actual result:
It works well, as expected
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.