Closed Bug 898353 Opened 8 years ago Closed 8 years ago

[User Story] Setting Timer

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pdol, Assigned: rwaldron)

References

Details

(Keywords: feature, Whiteboard: [ucid:Productivity31])

User Story:

As a user I want to be able to set a count down timer by inputting a time duration so that I do not need to manually keep track of the elapsed time.


Acceptance Criteria:

1. After I input a time duration, the timer shows that duration but does not begin the count down.
2. I am able to start the count down after I input a duration.
Accidental nom.  Not a blocking feature.
blocking-b2g: koi? → ---
Blocks: 898456
Depends on: 913002
Assignee: nobody → waldron.rick
https://mozilla.app.box.com/s/wzgsb3lkqglv0dnfdgzs/1/1092493904/9862011878/1

This view was designed with a "component" that does not exist. It assumes that the system HTML widgets for "pickers" and "selectors" was designed in such a way that they could be used for arbitrary data. This is not the case. The "pickers" and "selectors" are only scenario solvers and are constrained by their own implementation. 

- There is no existing way to create a multi-value picker as shown in the UI mock up
- Existing multi-value picker, eg. input type=time has no customization mechanism
- Existing multi-value picker seems hard-bound to the dialog that it opens in when a user focuses on a time input
- Existing multi-value picker can't be used as a work-around because it ALWAYS displays AM/PM
- Existing multi-value picker dialog offers no customization mechanism.

Not sure how to proceed. I have all the other pieces of the pie, except for this.
Flags: needinfo?(pdolanjski)
Flags: needinfo?(epang)
UX input needed.
Flags: needinfo?(pdolanjski) → needinfo?(firefoxos-ux-bugzilla)
Hi Rick,

A long time ago, there is an embedded time picker for setting alarm time. Then, we have a multi-value picker for system one(input type=time, date, ..). In side of implementation, the system multi-value picker is generated via embedded time picker of Clock app. Four months ago, UX have a decision to remove the embedded time pick from Clock app. So, that we use the system time picker in alarm setting page.(https://github.com/mozilla-b2g/gaia/commit/f21dfe973c315a171bf5d779143363602b5de629#diff-b3d199c0b2cbc31e4a6267c782ac97f5)
As your mention, the existing multi-value picker is no way for customization mechanism. It will pop out a dialog with 'Cancel', 'OK' dialog. That could be not UX's expected. I think we might have to implement an embedded picker for the page. If it's possible, provide a component for shared these kinds of picker. Hoping these information is useful for you. Thanks.
Flagging Rob since this is Clock.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
(In reply to Ian Liu [:ianliu] from comment #4)
> Hi Rick,
> 
> A long time ago, there is an embedded time picker for setting alarm time.
> Then, we have a multi-value picker for system one(input type=time, date,
> ..). In side of implementation, the system multi-value picker is generated
> via embedded time picker of Clock app. Four months ago, UX have a decision
> to remove the embedded time pick from Clock app. So, that we use the system
> time picker in alarm setting
> page.(https://github.com/mozilla-b2g/gaia/commit/
> f21dfe973c315a171bf5d779143363602b5de629#diff-
> b3d199c0b2cbc31e4a6267c782ac97f5)
> As your mention, the existing multi-value picker is no way for customization
> mechanism. It will pop out a dialog with 'Cancel', 'OK' dialog. That could
> be not UX's expected. I think we might have to implement an embedded picker
> for the page. If it's possible, provide a component for shared these kinds
> of picker. Hoping these information is useful for you. Thanks.

I asked about this and no response for 10 days. If I had waited for this response, I would've missed the cut-off day for 1.2 features. In the meantime, we've developed a simplified Picker that's composed of simplified Spinner objects. It looks and acts the way UX designs are specified.
Flags: needinfo?(epang)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This was implemented as per the UI spec in the build that we verified in 898353.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(rmacdonald)
You need to log in before you can comment on or make changes to this bug.