Closed Bug 8984 Opened 21 years ago Closed 21 years ago

[FEATURE] textarea wrap doesn't seem to be working

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: pcollins, Assigned: buster)

References

Details

(Whiteboard: fix in hand, will be checked in tomorrow if tree is in good shape)

Attachments

(1 file)

win 95
build ID 1999062808

the virtual wrap for this textarea doesn't seem to wrap.
scratch that I can't seem to duplicate.
Whiteboard: MAKINGTEST bmlynch@cs.uiowa.edu
Whiteboard: MAKINGTEST bmlynch@cs.uiowa.edu → TESTCASE bmlynch@cs.uiowa.edu
This bug is [4.xP] (works in ie4x and NN4x but not the mozilla builds)
The system I tested on: NT 4, SP5, p2 400
Mozilla build: 1999062508

None of the 'wrap' attributes of the textarea work. I've attached a simple test
case (it includes screenshots of expected behavior in NN4.6 and IE5 and the bug
in the mozilla build i listed).
Assignee: karnaze → buster
Reassigning to Steve.
Status: NEW → ASSIGNED
Summary: textarea wrap doesn't seem to be working → [FEATURE] textarea wrap doesn't seem to be working
marking as a FEATURE.  This has never been implemented.
*** Bug 2442 has been marked as a duplicate of this bug. ***
Target Milestone: M10
setting milestone to M10.
cc'ing mcafee and akkana who were interested. The original bug was bug 2442
moved to M11
Blocks: 12659
I'm putting this on the beta radar per morse's comment to
m.seamonkey.
here is a test comment from viewer with the fixed code.  This should give us two
 lines of text in the comment field, broken between "two" and "lines"
Whiteboard: TESTCASE bmlynch@cs.uiowa.edu → fix in hand, will be checked in tomorrow if tree is in good shape
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
fixed
Okay I am testing this fix out on windows 9/8 apprunner build because I just tried it on a linux 9/8 build (apprunner) and it was not word wrapping.
Okay, now I'm trying on a 9/8 Linux viewer build. La de da la de da de la la d eld dldld dld ea al
Status: RESOLVED → REOPENED
Re-opening. Steve, did you check this in?
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
This is either the same bug or it isn't.  Viewing bug 13604
( http://bugzilla.mozilla.org/show_bug.cgi?id=13604 )
in Mozilla M10 1999090809, some of the lines extend much longer than
the width of the comments window they were entered in. At entry time,
the text wrapped in the browser, but it was sent unwrapped - and I note
that the WRAP attribute on the "Additional Comments" textarea is HARD.
Submitting this comment twice from the same build, once with and once
without manual hard returns, for readablity and to act as its own testcase.
If the second repeat is all on one line, that's the bug.

This is either the same bug or it isn't.  Viewing bug 13604 ( http://bugzilla.mozilla.org/show_bug.cgi?id=13604 ) in Mozilla M10 1999090809, some of the lines extend much longer than the width of the comments window they were entered in. At entry time, the text wrapped in the browser, but it was sent unwrapped - and I note that the WRAP attribute on the "Additional Comments" textarea is HARD. Submitting this comment twice from the same build, once with and once without manual hard returns, for readablity and to act as its own testcase. If the second repeat is all on one line, that's the bug.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Please retest, this was fixed with GFX text controls which are now turned on by
default on linux and windows.  for mac, you'll have to turn them on using the
debug pref in apprunner preferences.
Status: RESOLVED → VERIFIED
verified with gfx widgets on, sorry for the confusion
You need to log in before you can comment on or make changes to this bug.