Suppress "Mozilla Firefox is free and open source" popup in cfx run

RESOLVED WORKSFORME

Status

Add-on SDK
General
P3
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Ralf Strobel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Start the browser with "cfx run" command in SDK 1.14, FF 22.


Actual results:

The browser always displays its first-run popup "Mozilla Firefox is free and open source..." at the top of the tabbed browser.


Expected results:

Suppress the popup by default. This can be achieved easily by adding the following line to /python-lib/cuddlefish/prefs.py under DEFAULT_COMMON_PREFS...

'browser.rights.3.shown' : True

Updated

5 years ago
Priority: -- → P3
Whiteboard: [good first bug]
I was *not* able to reproduce this bug with SDK 1.14, FF 23, 
either on Arch Linux x86_64 or on Windows 7 32-bit.

Please, confirm it further.
(Reporter)

Comment 2

5 years ago
Indeed. FF 23 doesn't seem to display the message any more. Not sure whether this is intentional or a bug, since I can't find anything about it in the change log.
(In reply to Ralf Strobel from comment #2)
> Indeed. FF 23 doesn't seem to display the message any more. Not sure whether
> this is intentional or a bug, since I can't find anything about it in the
> change log.

good to hear!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.